0.2.9: 8.7 support, with partly extended 0.3 compatibility in 0.2!

Status
Not open for further replies.

Fury

OtLand's Mascot
Joined
Feb 1, 2009
Messages
23
Reaction score
9
From The Forgotten Server development blog:
As mentioned in our last status update, we would try to deliver the release with 8.7 protocol support before Christmas and so we have. The 9th version of 0.2 was released earlier today with full 8.7 support which includes: a mount system, spell cooldowns (because we were first with this, our spells.xml format differs a bit from the otserv format, but compatibility has been added so that both formats work!) and protocol changes such as allowing very high numbers for the experience (64 bit). The items.otb included is also the official one, so you should be able to map with it and use new items on your map.

Besides the 8.7 protocol support, there has also been work by our new developer Fallen on extended 0.3 compatibility support in 0.2. The changes that are included in this release are a set of Lua functions, Lua functions returning real Lua booleans (true/false) instead of integers (requires patching the first lines in global.lua!), and global events.

The release thread can be found here: http://otland.net/f18/8-7-forgotten-...spirit-113069/.

I know most users have already ditched 0.2 for 0.3 and would like to have a status update on how it's going. Unfortunately I do not have much information about how 0.3.7 is proceeding. I have notified elf that it's time to release it soon and he agreed, but it seems to have an amount of known bugs that must be addressed first.

Merry Christmas!
 

Exedion

Excellent OT User
Joined
Jun 11, 2007
Messages
628
Reaction score
28
Thanks for the information! solve my dudes... but will be nice know when 0.3 series will be update
 

Elexonic

Excellent OT User
Joined
Jun 18, 2008
Messages
1,921
Reaction score
55
I hope you solve the makeshift faster with 0.3.
Thanks
 

samuel157

/root
Joined
Mar 19, 2010
Messages
53
Reaction score
0
server left no command /attr and to put
god has to put
type and group aff
 

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,833
Reaction score
181
Location
Texas
@up ommmg you actually have todo something to the server, ommmmggggg thats terrrible :(
 

Myway

New Member
Joined
May 7, 2008
Messages
15
Reaction score
0
hi guys
we all know how forgottenserver is very good but i had bad propralmes with it and modren acc
so i start working at theforgottenserver-v0.2.9-win32gui thats call Mystic Spirit and its wonderfull
but something happend when i try to setup my ModernAAC to make website
ModernAAC didnt use the same row id in phpmyadin ~~~~

like there is column in fts call type its refer if the account adim or gm or just normal player
the one work with fts

the one work with ModernAAC 1.01

and you cant change it or delet it lolz coz server we got mad and never work and if you leave it you got bug at ModernAAC1 website its say type column unknow but at ModernAAC1.01 that it use old groups.xml system maybe i just use an old ModernAAC or maybe i need an old one work with 2.9
idk or maybe there is TUTORIAL to how changeing in TUTORIAL! but really i cant fiend that! so if you know something try to help me ! coz iam new here!

sorry for my english!
 
Status
Not open for further replies.
Top