• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

TFS 1.X+ Error in console regarding login

Hawkeye

New Member
Joined
Dec 21, 2009
Messages
13
Reaction score
0
Location
Thais
Hello there, im using MyAAC and can create account just fine on my site with no problems, it also shows that my server is online too but when i try to login to the game it says "Account name or password is not correct" and in the console it shows this message.

HTML:
 [Error - mysql_real_query] Query: SELECT [ICODE]id[/ICODE], [ICODE]name[/ICODE], [ICODE]password[/ICODE], [ICODE]secret[/ICODE], [ICODE]type[/ICODE], [ICODE]premdays[/ICODE], [ICODE]lastday[/ICODE] FROM [ICODE]accounts[/ICODE] WHERE [ICODE]name[/ICODE] = '654321'
Message: Unknown column 'premdays' in 'field list'
[Error - mysql_store_result] Query: SELECT [ICODE]id[/ICODE], [ICODE]name[/ICODE], [ICODE]password[/ICODE], [ICODE]secret[/ICODE], [ICODE]type[/ICODE], [ICODE]premdays[/ICODE], [ICODE]lastday[/ICODE] FROM [ICODE]accounts[/ICODE] WHERE [ICODE]name[/ICODE] = '654321'
Message: Unknown column 'premdays' in 'field list'

i didnt have any errors while setting up on phpmyadmin or myacc.

any help would be greatly appreciated

Tom
 
Last edited:
OP
OP
H

Hawkeye

New Member
Joined
Dec 21, 2009
Messages
13
Reaction score
0
Location
Thais

premdays got changed to premium_ends_at
thanks for the reply, im just wondering where to put that in, such as on a phpmyadmin page or in a folder somewhere, ive tried on phpmyadmin but show up with red crosses saying "unrecognized statement type" and if i do press go anyway it shows up with red errors. or am i just being stupid? sorry.

EDIT: i found the file data/migrations/26.lua and it is already the same as what that link refers me to. or is it more of an issue with using MyAAC and that what you mean @Evil Puncker with opening up the issue on github?

sorry for being a pain, just trying to learn and teach myself.
 
Last edited:

Leesne

i r peekay
Premium User
Joined
Dec 4, 2017
Messages
346
Solutions
34
Reaction score
188
Location
UK
What version of my aac are you using as this was implemented in
[0.8.4 - 18.02.2021]
- support for accounts.premium_ends_at (Latest TFS 1.x)
and is in a Dev and main build with a check to see if column, premdays or premium_ends_at exists.

Also what TFS are you using?
That looks like a server error for the premdays and not relating to myaac?
 
OP
OP
H

Hawkeye

New Member
Joined
Dec 21, 2009
Messages
13
Reaction score
0
Location
Thais
MyAcc is version 0.8.6
and
The Forgotten Server - Version 1.2
Compiled with Microsoft Visual C++ version 14.0
Compiled on Oct 22 2016 03:25:53 for platform x64

also in the accounts secontion on phpmyadmin it has a column with premium_ends_at if thats any help either.

thanks for your time.
 

Leesne

i r peekay
Premium User
Joined
Dec 4, 2017
Messages
346
Solutions
34
Reaction score
188
Location
UK
Unless its just because I'm really tired. This is related to your database and not MyAAC.
If you have run migration 26, it has removed the field you need.
TFS 1.4 uses the new premium_ends_at not 1.2 which uses premdays.
TFS 1.2 is showing migrations up to 19.

Have you mixed files together?
If so you have prob broken more than just the prem days.

you will need to alter your accounts table to readd.
SQL:
`premdays` int(11) NOT NULL DEFAULT '0'
 
Top