• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!
  • If you're using Gesior 2012 or MyAAC, please review this thread for information about a serious security vulnerability and a fix.

OTClient HELP TO OPEM items.otb

douglasscherner

New Member
Joined
Aug 15, 2014
Messages
64
Reaction score
3
I am unsuccessful in opening this file using Item Editor.
All versions I download are incompatible.

Can someone help me?

I need to edit to remove some items that are debugging.
Thanks.
 

Attachments

Itutorial

Excellent OT User
Joined
Dec 23, 2014
Messages
2,279
Solutions
68
Reaction score
919

You may need to open plugins/PluginThree.xml and modify the spr/dat address
XML:
<settings>
    <clients>
        <client version="1010" description="Client 10.10" otbversion="50" datsignature="51E3F8C3" sprsignature="51E3F8E9"/>
        <client version="1020" description="Client 10.20" otbversion="51" datsignature="5236F129" sprsignature="5236F14F"/>
        <client version="1021" description="Client 10.21" otbversion="52" datsignature="526A5068" sprsignature="526A5090"/>
        <client version="1030" description="Client 10.30" otbversion="53" datsignature="52A59036" sprsignature="52A5905F"/>
        <client version="1031" description="Client 10.31" otbversion="54" datsignature="52AED581" sprsignature="52AED5A7"/>
        <client version="1041" description="Client 10.41" otbversion="55" datsignature="5383504E" sprsignature="53835077"/>
        <client version="1077" description="Client 10.77" otbversion="56" datsignature="38DE" sprsignature="5525213D"/>
        <client version="1098" description="Client 10.98" otbversion="57" datsignature="42A3" sprsignature="57BBD603"/>
    </clients>
</settings>


If you have a custom version or one thats not listed just add it like this:
XML:
<client version="1080" description="Client 10.80" otbversion="56" datsignature="newSig" sprsignature="newSig"/>

It may error and say its a different otbversion. Just type the otbversion in otbversion="56" should be good to go.
 
OP
OP
douglasscherner

douglasscherner

New Member
Joined
Aug 15, 2014
Messages
64
Reaction score
3
So I put :


XML:
   <client version="1101" description="Client 11.01" otbversion="62" datsignature="4C28B721" sprsignature="4C220597"/>


When i select .dat and .spr of tibia says:
OTB version 62.
PluginThree: Error while parsing, unknown flag 0x84 at id 100.
Failed to load dat.
Loading client files.
Client version 1101.

my .dat and spr files are here:

 
Last edited:

Itutorial

Excellent OT User
Joined
Dec 23, 2014
Messages
2,279
Solutions
68
Reaction score
919
Check if you have extended or transparent selected. Try to play with those. If it still doesn't work then I would imagine it has to do with whatever object builder you are using.
 

Gesior.pl

Mega Noob&LOL 2012
Senator
Premium User
Joined
Sep 18, 2007
Messages
2,765
Solutions
91
Reaction score
2,787
Location
Poland
GitHub
gesior
WHERE did you get this file?
I've talked with 2 guys last week, they made changes to Item Editor (and OTC), to make it work with their custom .otb/.dat format.
You got no chance to open it using any open source tool, as they use changes that allow to use over 65k items (changed 16 bit number to 32 bit) and other 'features' (not related to any known Tibia client).
 
OP
OP
douglasscherner

douglasscherner

New Member
Joined
Aug 15, 2014
Messages
64
Reaction score
3
WHERE did you get this file?
I've talked with 2 guys last week, they made changes to Item Editor (and OTC), to make it work with their custom .otb/.dat format.
You got no chance to open it using any open source tool, as they use changes that allow to use over 65k items (changed 16 bit number to 32 bit) and other 'features' (not related to any known Tibia client).
I founded this editor im this website:
 

Gesior.pl

Mega Noob&LOL 2012
Senator
Premium User
Joined
Sep 18, 2007
Messages
2,765
Solutions
91
Reaction score
2,787
Location
Poland
GitHub
gesior
I founded this editor im this website:
I mean, where did you get .otb file, that you cannot open with open source .otb editors.
 

Gesior.pl

Mega Noob&LOL 2012
Senator
Premium User
Joined
Sep 18, 2007
Messages
2,765
Solutions
91
Reaction score
2,787
Location
Poland
GitHub
gesior
I buyed a server and it came with this .otbm.
:(
I've seen a lot of 'servers for sell'.
Their most important problem is: if someone sells server, it means it cannot generate enough income to pay for VPS and development.
Probably it's bugged (crash) or it has so chaotic code, that you cannot find out why there are some problems = cannot continue development.

If someone sells .otb with content not compatibile with any official Tibia protocol [ex. 8.60 or 10.98], they should also deliver tools to develop it.
 
Top