• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

AAC [MyAAC v0.8.2] SMTP Error

croix

Member
Joined
Aug 26, 2011
Messages
123
Reaction score
13
So I've tried like everything I can find..

Code:
2020-12-20 02:33:11    SMTP ERROR: Failed to connect to server:  (0)

This is the config I use

PHP:
// mail
'mail_enabled' => true, // is aac maker configured to send e-mails?
'mail_address' => '[email protected]', // server e-mail address (from:)
'mail_admin' => '[email protected]', // admin email address, where mails from contact form will be sent
'mail_signature' => array( // signature that will be included at the end of every message sent using _mail function
'plain' => ''/*'--\nMy Server,\nhttp://www.myserver.com'*/,
'html' => ''/*'<br/>My Server,\n<a href="http://www.myserver.com">myserver.com</a>'*/
),
'smtp_enabled' => true, // send by smtp or mail function (set false if use mail function)
'smtp_host' => 'smtp.gmail.com', // mail host
'smtp_port' => 465, // 25 (default) / 465 (ssl, e.g. gmail)
'smtp_auth' => true, // need authorization?
'smtp_user' => '[email protected]',
'smtp_pass' => 'example',


(I've changed user/pass and mail_adress etc to my own gmail)

Any clues?
 
OP
OP
croix

croix

Member
Joined
Aug 26, 2011
Messages
123
Reaction score
13
Yeah, I've tried that aswell, I just get a new error.

Lua:
SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
2020-12-20 02:56:07    SERVER -> CLIENT: 220 smtp.gmail.com ESMTP a9sm1493339lfl.143 - gsmtp
2020-12-20 02:56:07    CLIENT -> SERVER: EHLO localhost
2020-12-20 02:56:07    SERVER -> CLIENT: 250-smtp.gmail.com at your service, [IP]
                                         250-SIZE 35882577
                                         250-8BITMIME
                                         250-STARTTLS
                                         250-ENHANCEDSTATUSCODES
                                         250-PIPELINING
                                         250 SMTPUTF8
2020-12-20 02:56:07    CLIENT -> SERVER: STARTTLS
2020-12-20 02:56:07    SERVER -> CLIENT: 220 2.0.0 Ready to start TLS
2020-12-20 02:56:07    SMTP Error: Could not connect to SMTP host.
2020-12-20 02:56:07    CLIENT -> SERVER: QUIT
2020-12-20 02:56:07    SERVER -> CLIENT:
2020-12-20 02:56:07    SMTP ERROR: QUIT command failed:
2020-12-20 02:56:07    SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

Any chance gmail changed SMTP host? I will try and change.
 

Evil Puncker

prolonged absenteeism
TFS Developer
Joined
May 30, 2009
Messages
8,038
Solutions
215
Reaction score
3,878
you can't have both configs set to true, read the comment: 2020-12-20 00_11_23-[TFS 0.36] SMTP Error _ OTLand.png

btw my advice is to use only 'mail_enabled' => true and not the smtp one, its way easier
 

Evil Puncker

prolonged absenteeism
TFS Developer
Joined
May 30, 2009
Messages
8,038
Solutions
215
Reaction score
3,878
I've tried both options, 'mail_enabled' doesn't give me an error, but it doesn't send a mail.
what AAC are you using? you might have to install PHPMailer (just download and extract) but that depends on which AAC you are using since you didn't told us anything
 

slaw

Developer
Joined
Aug 27, 2007
Messages
3,284
Solutions
101
Reaction score
772
Location
Germany
GitHub
slawkens
Yes, MyAAC have PHPMailer included by default, so you don't need to install anything.

My first thought was, maybe you don't have openssl extension installed?

Go to MyAAC Admin Panel -> Tools -> phpinfo, search for "openssl" and check if you have something like that:

1608476345660.png
 
OP
OP
croix

croix

Member
Joined
Aug 26, 2011
Messages
123
Reaction score
13
Yes, MyAAC have PHPMailer included by default, so you don't need to install anything.

My first thought was, maybe you don't have openssl extension installed?

Go to MyAAC Admin Panel -> Tools -> phpinfo, search for "openssl" and check if you have something like that:

View attachment 52741


I think I've setup that correctly -
1608536983710.png


I ran into these exact errors when trying to use myaac hosted on an amazon aws instance. Works fine on other hosting platforms.
Do you happen to be hosting your website on AWS?

Hosting via UniServer Zero XIV
 

Three Magic

u aint shit
Joined
Aug 25, 2009
Messages
8,872
Solutions
1
Reaction score
694
Hi @croix

Make sure IMAP is enabled in webmail, open gmail > settings > see all settings > forwarding and pop/imap tab > imap access > enable imap

Your settings look fine with SSL / 465.

Edit:
Further to add if the above doesn't work, turn on Less Secure Apps and turn off 2FA if it's enabled or create an App password.
Less secure app access (google.com)

Thanks
 
Last edited:
OP
OP
croix

croix

Member
Joined
Aug 26, 2011
Messages
123
Reaction score
13
Hi @croix

Make sure IMAP is enabled in webmail, open gmail > settings > see all settings > forwarding and pop/imap tab > imap access > enable imap

Your settings look fine with SSL / 465.

Edit:
Further to add if the above doesn't work, turn on Less Secure Apps and turn off 2FA if it's enabled or create an App password.
Less secure app access (google.com)

Thanks

Thanks! I sure will try.
 
Top