• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!
  • If you're using Gesior 2012 or MyAAC, please review this thread for information about a serious security vulnerability and a fix.

bad argument #1 to 'ipairs' (table expected, got nil) | TFS 1.5 8.6

vexler222

Member
Joined
Apr 22, 2012
Messages
618
Solutions
13
Reaction score
23
Hi, so after long battle with mana/life leech and critical hit, i fixed it, BUT there is a new problem
After set luaItemDesc for TRUE, i get this errors when im try look on items with some skills like protection, attack etc
Only items without attributes, show a description.
Someone maybe have any ideas, where search problem? What a sources file are connected with lib/core/item.lua?


1655993114526.png

In sources for clinet 7.72 all work perfect, so i think there is more missing lines in sources for 8.6

Code:
        -- Special Skills
        for specialSkill, value in ipairs(abilities.specialSkills) do -- this is line 173
            if value ~= 0 then
                begin = addSeparator(ss, begin)
                ss:append('%s %s%d%%', getSpecialSkillName(specialSkill - 1), showpos(value), math.abs(value))
            end
        end
 

Dakos

Active Member
Joined
Jan 1, 2010
Messages
73
Solutions
12
Reaction score
35
Lua:
        -- Special Skills
        if abilities.specialSkills then
            for specialSkill, value in ipairs(abilities.specialSkills) do -- this is line 173
                if value ~= 0 then
                   begin = addSeparator(ss, begin)
                   ss:append('%s %s%d%%', getSpecialSkillName(specialSkill - 1), showpos(value), math.abs(value))
                end
            end
        end
 
OP
OP
vexler222

vexler222

Member
Joined
Apr 22, 2012
Messages
618
Solutions
13
Reaction score
23
Lua:
        -- Special Skills
        if abilities.specialSkills then
            for specialSkill, value in ipairs(abilities.specialSkills) do -- this is line 173
                if value ~= 0 then
                   begin = addSeparator(ss, begin)
                   ss:append('%s %s%d%%', getSpecialSkillName(specialSkill - 1), showpos(value), math.abs(value))
                end
            end
        end

I forgot to set this thread a solved, @Nekiro helped me on private message, here is a solution for this error in tfs 1.5 8.6
 
Top