• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

TFS 1.X+ Cannot connect with host computer

zirra

Member
Joined
Jun 11, 2009
Messages
343
Solutions
1
Reaction score
7
Location
Arizona, Usa
Self hosting, opened the server and cannot get past the IP Loopback issue. loads char list, and times out after selecting character.

Yes, I have searched these forums, similar problems, but none of the solutions work which is why I'm posting a new thread.

Hosts changed and saved? Yes
Others can connect? Yes
I can connect on same network with other PC
I can access website from host PC
Config.lua is updated with domain name.

I've tried IPv4, Localhost/127.0.0.1, and domain.
I've added all IPs to hosts file.

What am I missing here? Am I doomed? XD
 

Silba

is stephany, the josh wife
Premium User
Joined
Aug 22, 2013
Messages
389
Solutions
9
Reaction score
305
There are two issues that prevent people from accessing their own server either via localhost or their own globalIP / created domain.
One is that you haven't forwarded your ports 7171 and 7172 for both tcp and udp. If you have done this, and you're sure they're opened (you've used port checker) then the issue is most likely that your router doesn't offer nat loopback. Routers that don't offer nat loopback as a security feature generally don't have a setting in their admin panel to enable it. I would suggest you download microsoft's nat loopback, you can do this by right clicking "My Computer" and clicking "Manage". Once you've done that you want to click Device Manager and you'll see a list come up. On the top of that list is your computer name (its the one above audio inputs and outputs) right click on that and click Install Legacy Hardware. Click on next and push install MANUALLY. Another list will pop up, scroll down to network adapters, click that and click next. On the left panel you want to select Microsoft and on the right side scroll down until you find Microsofts KM-Test Loopback and install that. Once that is finished, open your networks and right click on the newly created "Ethernet 2" and click on properties. Scroll down until you find the IP4V setting and open that. You want to switch it from automatic to manual and for the IP input your GLOBAL IP from www.whatismyip.com. The next spot should fill in automatically (255.255.255.0) and leave the lost slot empty. For your DNS manually change that to 192.168.1.1 and select OK and then you can close out of everything, reset your server and log in with your global / domain rerouted IP :)
Maybe you need to do this, i spent hours troubleshooting with people and nothing worked but this worked first time and every time since. Many new ISP routers for the past few years don't have loopback. I have no idea why this community hasn't picked up on it and it's not officialy documented in the FAQ or something as it probably stops many people developing OTs.
 
Top