• Congratulations to the OTLand February Mapping Competition Winner! The grand prize of Otland Premium goes to eiserne festung.
  • There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

TFS 1.X+ Can't build the server

RickJF

New Member
Joined
Feb 22, 2021
Messages
2
Reaction score
0
I've been trying to build the forgotten server for about 2 days now I I can't make it work.

I'm using a freshly installed ubuntu 16.10 server and the Boost library is just broken, no matter what I do it just isn't installed.

Can anyone help me? Even a compiled version would do, this is so frustrating.
 

beliar34

Member
Joined
Feb 28, 2012
Messages
299
Solutions
7
Reaction score
10
Reinstall everything, make fresh ubuntu 16 installation and then :

Lua:
apt-get update && upgrade -y
do-release-upgrade
apt-get update && upgrade -y
apt-get autoremove
And then follow some tutorial how to compile TFS
 

Don Daniello

/root
Staff member
Administrator
Joined
Apr 11, 2008
Messages
3,611
Solutions
14
Reaction score
1,145
Location
Proland
Ubuntu 16.10 is EOL, you should not be using it. It likely won't have the boost version that is required in latest TFS.
 
OP
RickJF

RickJF

New Member
Joined
Feb 22, 2021
Messages
2
Reaction score
0
Thanks for your replies guys. You are very right about that Don, and after a lot of work I managed it.

Sadly thats the only way I can host for a reasonable price in my country, anything more complex, up to date, or dedicated costs trice as much.

For anyone struggling with this, I had to compile and manually link (sym links) the whole Boost package. There are several tutorial in the Boost website, but the key is, after suffering with the whole process, link the compiled result yourself to the route your server is using to load the libraries, It should be all over the errors xD.
 
Top