• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

TFS 0.X Can't login on my server sometimes

ZowN

Member
Joined
Mar 19, 2015
Messages
48
Best answers
1
Reaction score
20
TFS 0.4

So every now and then I'm unable to login.

This is how it plays out:

I start the server, it runs without problems.
After some time (sometimes after 10 min, sometimes it's fine for days) but what happens is that the server freezes(Everyone online loses connection to the server).
When others or me try to login after this has happened, you can only get as far as character list, then when you try to connect, it just keeps trying to connect.
The characters who were logged on still stays online in the server though, if they were in a fight and I don't shut down the server immediatly then their character died during this time.

CMD shows no errors.
By restarting the server everything works as normal again.

Has anyone encountered this before and/or know what the underlying problem might be?
Could the culprit be the hosting machine ( OVH ) ?
 

Ralumbi

Active Member
Joined
Sep 27, 2018
Messages
56
Best answers
0
Reaction score
25
Location
The Netherlands
TFS 0.4

So every now and then I'm unable to login.

This is how it plays out:

I start the server, it runs without problems.
After some time (sometimes after 10 min, sometimes it's fine for days) but what happens is that the server freezes(Everyone online loses connection to the server).
When others or me try to login after this has happened, you can only get as far as character list, then when you try to connect, it just keeps trying to connect.
The characters who were logged on still stays online in the server though, if they were in a fight and I don't shut down the server immediatly then their character died during this time.

CMD shows no errors.
By restarting the server everything works as normal again.

Has anyone encountered this before and/or know what the underlying problem might be?
Could the culprit be the hosting machine ( OVH ) ?
Did you setup anything like an auto-restarter? Also it makes me unclear if you're running windows or linux.
If its in linux I will be able to check further with you on this issue. If windows I can as well, but I do rather not work with windows.

Sometimes when you have got a restarter running it will just restart, which creates an secondary process running in the same level of the primary process which end up in a crash even when it doesn't look like a crash in first place.

Sincerely,
Ralumbi
 
OP
ZowN

ZowN

Member
Joined
Mar 19, 2015
Messages
48
Best answers
1
Reaction score
20
I sent you a message but to give information to other viewers, this occurred without an auto-restarter.
We operate on windows.
 

Demnish

Tibian Hero
Joined
Sep 28, 2011
Messages
385
Best answers
2
Reaction score
46
Location
Sweden
Sounds like a source based memory leak issue.
Might also be some script that is hogging memory by storing variables, building up a lot over time until the server eventually can't handle the info.
Alternatively, if you're using a custom client, there could be compatible issues aswell.

A computer who stores all information it can, will eventually break if it can't dump that information.
That is why a human's memory is selective. Why we sometimes forget things; it's because our mind has deemed that information non-vital and thus dumped it to save itself from crashing.

So start with checking your scripts, then sources etc.
At least that is what I personally would start with.
 
Last edited:
Top