• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

TFS 1.X+ [Custom Item] The Regeneration Effects isn't working

magoale1

New Member
Joined
Jun 12, 2014
Messages
14
Best answers
0
Reaction score
0
Location
Brazil
Hello, im trying to make a helmet that regens 2 mana per second and the actual code is this:
36994
Why it isn't working? The item shows in the game perfectly well and even in the name there is (faster regeneration) but it doesn't regen.
 

Evil Hero

Legacy Member
TFS Developer
Joined
Dec 12, 2007
Messages
1,210
Best answers
21
Reaction score
583
Location
Germany
You need to register this item in movements.xml aswell.
XML:
<movevent event="Equip" itemid="26382" slot="head" function="onEquipItem" />
<movevent event="DeEquip" itemid="26382" slot="head" function="onDeEquipItem" />
 
OP
magoale1

magoale1

New Member
Joined
Jun 12, 2014
Messages
14
Best answers
0
Reaction score
0
Location
Brazil
Thanks it worked!!
But people cannot join my server, it remains "Connecting to the game world" and don't enter.
What can be the problem? It worked yesterday and i didn't changed nothing.
 
Last edited:

Xikini

I whore myself out for likes
Joined
Nov 17, 2010
Messages
4,316
Best answers
197
Reaction score
2,343
Thanks it worked!!
But people cannot join my server, it remains "Connecting to the game world" and don't enter.
What can be the problem? It worked yesterday and i didn't changed nothing.
Don't know much about your setup, but just verify that everything is indeed, not changed.
Confirm your IP is still the same.
Confirm that your internal router ip is still the same.
Confirm that ports are still forwarded.

If you're using a url instead of direct IP, make sure that the URL is pointing to the correct IP address.
 
Top