• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Help compiling saiyanskings optimized server

Felipe93

Ghost Member
Joined
Mar 21, 2015
Messages
1,754
Solutions
9
Reaction score
281
Location
Chile
Heelo im trying to compiling sayiyansking optimized server and im getting this error

fatal error C1083: Cannot open include file: 'gmp.h'

im using msvc 2017 i've changed this


JoinedMar 4, 2017Messages2,429Solutions302Reaction score1,006LocationEgypt
I just compiled it using Visual Studio 2019/vcpkg
Code:
========== Rebuild All: 1 succeeded, 0 failed, 0 skipped ==========
Windows SDK version: 8.1
Platform Toolset: Visual Studio 2017 (v141)
I also had to change in \vc14\settings.props
libmysql.lib to libmariadb.lib
and zlib1.lib to zlib.lib
Try doing the same if you still getting errors then remove vcpkg and restart all the steps slowly, Create a Support thread also, We are bumping this too much.

but the errors with gmp.h is still there

someone adviced my to reinstall vckpg + ñibs but im not quite sure the problem is there cuz i've compiled otc and other server without problems
i forgot to menthion that i enabled vckpg integration via powersheell aswell..

thanks in advance
 
Solution
Maybe you have old libs/includes added to Environment Variables then Visual Studio reads both vcpkg/old ones and gets conflicted?
Also check vcpkg\packages\mpir_x64-windows\include if you have gmp.h there
and try installing GMP manually by using this command
Bash:
./vcpkg install gmp[core]:x64-windows

M0ustafa

1337
Senator
Joined
Mar 4, 2017
Messages
2,560
Solutions
315
Reaction score
1,132
Location
Egypt
Maybe you have old libs/includes added to Environment Variables then Visual Studio reads both vcpkg/old ones and gets conflicted?
Also check vcpkg\packages\mpir_x64-windows\include if you have gmp.h there
and try installing GMP manually by using this command
Bash:
./vcpkg install gmp[core]:x64-windows
 
Last edited:
Solution
OP
OP
Felipe93

Felipe93

Ghost Member
Joined
Mar 21, 2015
Messages
1,754
Solutions
9
Reaction score
281
Location
Chile
even after updating vckpg :/

it's pretty weird
Git:
Error: Building package gmp:x64-windows failed with: BUILD_FAILED
Please ensure you're using the latest portfiles with `.\vcpkg update`, then
submit an issue at https://github.com/Microsoft/vcpkg/issues including:
  Package: gmp:x64-windows
  Vcpkg version: 2021-01-13-d67989bce1043b98092ac45996a8230a059a2d7e

Additionally, attach any relevant sections from the log files above.
PS D:\vcpkg>


edit after a bit of search i found this


I used ./vcpkg install yasm-tool: x86-windows and then ./vcpkg install gmp: x64-windows
And it works, thanks @M0ustafa
 

chucky91

Active Member
Joined
Apr 8, 2010
Messages
80
Reaction score
44
Maybe you have old libs/includes added to Environment Variables then Visual Studio reads both vcpkg/old ones and gets conflicted?
Also check vcpkg\packages\mpir_x64-windows\include if you have gmp.h there
and try installing GMP manually by using this command
Bash:
./vcpkg install gmp[core]:x64-windows
my problem with the build is that i don't have GMP, now i'm installing it.
 

ralke

(҂ ͠❛ ෴ ͡❛)ᕤ
Joined
Dec 17, 2011
Messages
897
Solutions
21
Reaction score
427
Location
Santiago - Chile
I used ./vcpkg install yasm-tool: x86-windows and then ./vcpkg install gmp: x64-windows
And it works, thanks @M0ustafa

Hi @Felipe93 did you encounter this error when installing gmp?
vcpkg gmp.png

Also tried to run
Code:
./vcpkg install yasm:x64-windows-static

Like is mentioned here

But has this error
yasm.png
 
Top