.my.cnf , .config missing / running server from host?

wickedd

Intermediate OT User
Joined
Oct 14, 2011
Messages
244
Best answers
1
Reaction score
21
Location
US
I just got a host and I'm trying to setup the website. I followed the wiki and moved all my website files to /home/otsmanager/www/public_html and changed path server to'home/otsmanager/forgottenserver' im getting this error with starting the server
Lua:
● tfs.service - The Forgotten Server Loaded: loaded (/home/otsmanager/.config/systemd/user/tfs.service; enabled; vendor preset: enabled) Active: inactive (dead) (Result: exit-code) since Wed 2018-08-08 21:23:28 CEST; 51min ago Main PID: 25919 (code=exited, status=203/EXEC)

Aug 08 21:23:28 host.spigu.net systemd[26655]: tfs.service: Unit entered failed state. Aug 08 21:23:28 host.spigu.net systemd[26655]: tfs.service: Failed with result 'exit-code'. Aug 08 21:23:28 host.spigu.net systemd[26655]: tfs.service: Service hold-off time over, scheduling restart. Aug 08 21:23:28 host.spigu.net systemd[26655]: Stopped The Forgotten Server. Aug 08 21:23:28 host.spigu.net systemd[26655]: tfs.service: Start request repeated too quickly. Aug 08 21:23:28 host.spigu.net systemd[26655]: Failed to start The Forgotten Server.
and i get this error with the website
Lua:
 Notice: Use of undefined constant LINUX - assumed 'LINUX' in /home/otsmanager/www/public_html/config.php on line 683

Warning: mysqli::[I]_construct(): (HY000/1045): Access denied for user 'ClassicWar'@'localhost' (using password: YES) in /home/otsmanager/www/public[/I]html/engine/database/connect.php on line 278 Failed to connect to MySQL: (1045) Access denied for user 'ClassicWar'@'localhost' (using password: YES)
the wiki says there is a file with the name -- /home/otsmanager/.my.cnf - MySQL client config (contains root password)

but i cant find it anywhere,nor can i find any folder with the name config, or .config for ... /home/otsmanager/.config/systemd/user/tfs.conf is where your TFS systemd service unit file lives /home/otsmanager/.config/systemd/user/ is where you can put additional systemd service unit files at a user level
 
Last edited:

Mister Budex

BudexOT.com
Joined
Jun 22, 2016
Messages
1,146
Best answers
18
Reaction score
200
if you need help, send me private message and ill do that host for u
 
OP
wickedd

wickedd

Intermediate OT User
Joined
Oct 14, 2011
Messages
244
Best answers
1
Reaction score
21
Location
US
Thank you both for the reply. I was able to get the website to work, even though it still says this at the top of the website
Notice: Use of undefined constant LINUX - assumed 'LINUX' in /home/otsmanager/www/public_html/config.php on line 683
(Why does it say this? The host is linux. It even spells it out for me in the script beforehand
PHP:
// What kind of computer are you hosting this website on?
    // Available options: LINUX or WINDOWS
    $config['os'] = LINUX;
Use of undefined constant, LINUX is undefined, do i need to add LINUX somewhere in root?

I'm still having trouble starting the actual server itself too.
I can use SSH in PuTTY but i get the same error as before
Code:
● tfs.service - The Forgotten Server
   Loaded: loaded (/home/otsmanager/.config/systemd/user/tfs.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Thu 2018-08-09 02:05:17 CEST; 41min ago
 Main PID: 553 (code=exited, status=203/EXEC)
Aug 09 02:05:16 -host systemd[338]: tfs.service: Unit entered failed state.
Aug 09 02:05:16 host systemd[338]: tfs.service: Failed with result 'exit-code'.
Aug 09 02:05:17 host systemd[338]: tfs.service: Service hold-off time over, scheduling restart.
Aug 09 02:05:17 host systemd[338]: Stopped The Forgotten Server.
Aug 09 02:05:17 host systemd[338]: tfs.service: Start request repeated too quickly.
Aug 09 02:05:17 host systemd[338]: Failed to start The Forgotten Server.
I am using windows so i tried to follow these steps here DevelopersPL/otshosting-provisioning
but after the line "debconf-set-selections" it says debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords

Found this Windows OTs Hosting Service , updated website folder www and server folder to grant these permissions, and i still get the error that i do not have permissions
I went onward and installed wine, when i try to manually test it it comes back with this
Code:
wine: created the configuration directory '/home/otsmanager/.wine'
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
err:systray:initialize_systray Could not create tray window
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
fixme:storage:create_storagefile Storage share mode not implemented.
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
err:mscoree:LoadLibraryShim error reading registry key for installroot
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
fixme:storage:create_storagefile Storage share mode not implemented.
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:iphlpapi:NotifyAddrChange (Handle 0x101e368, overlapped 0x101e380): stub
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
fixme:storage:create_storagefile Storage share mode not implemented.
err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
fixme:iphlpapi:NotifyAddrChange (Handle 0x10be8a0, overlapped 0x10be8ac): stub
wine: configuration in '/home/otsmanager/.wine' has been updated.
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set correctly.
wineconsole: Starting program "tfs.exe" failed.
The command is invalid.
I can't run my server at all. Am I destroying the files somehow? Was I supposed to do it before this command? Whenever I try to run I get
Code:
● tfs.service - The Forgotten Server
   Loaded: loaded (/home/otsmanager/.config/systemd/user/tfs.service; enabled; vendor preset: enabled)
   Active: inactive (dead) (Result: exit-code) since Thu 2018-08-09 02:05:17 CEST; 3h 20min ago
 Main PID: 553 (code=exited, status=203/EXEC)
Aug 09 02:05:16 host systemd[338]: tfs.service: Unit entered failed state.
Aug 09 02:05:16 host systemd[338]: tfs.service: Failed with result 'exit-code'.
Aug 09 02:05:17 host systemd[338]: tfs.service: Service hold-off time over, scheduling restart.
Aug 09 02:05:17 host systemd[338]: Stopped The Forgotten Server.
Aug 09 02:05:17 host systemd[338]: tfs.service: Start request repeated too quickly.
Aug 09 02:05:17 host systemd[338]: Failed to start The Forgotten Server.
Aug 09 05:14:14 host systemd[338]: Stopped The Forgotten Server.
[code]
 
Last edited:

Don Daniello

/root
Staff member
Administrator
Joined
Apr 11, 2008
Messages
3,506
Best answers
15
Reaction score
895
Location
Proland
You probably wanted to use:
PHP:
$config['os'] = 'LINUX';
You shouldn't install Wine unless you have to run exe. You definitely bloated your server. You need to run the TFS binary in foreground to see the actual startup errors.
 
OP
wickedd

wickedd

Intermediate OT User
Joined
Oct 14, 2011
Messages
244
Best answers
1
Reaction score
21
Location
US
You probably wanted to use:
PHP:
$config['os'] = 'LINUX';
You shouldn't install Wine unless you have to run exe. You definitely bloated your server. You need to run the TFS binary in foreground to see the actual startup errors.
I did enter LINUX and it gave me that error. I guess that line was not needed , I just removed it. Seems to work fine.

I do in fact have an exe.
Yesterday i deleted all the website and server files and added clean ones from backup. Today I added clean exe and .dll files from backup(after attempting to run a few times), and looked through very page of Sigu Support on Otland. It looks like there is a wide variety of things that can go wrong.
I found someone saying to do this "configure tfs version in .tfs-version file. " but maybe it's outdated. It was on the fifth page. I can't find that file anywhere.

I ran TFS in foreground
/home/otsmanager/forgottenserver/build/tfs.exe - or ./forgottenserver/build/tfs.exe
(i believe this is the right way got it from here Solved - Problems running my OTS 8.6) and it came back

-bash: /home/otsmanager/forgottenserver/build/tfs.exe: Permission denied

I then deleted IIS_IUSRS permissions on the server folder(see above), moved that folder again to the host, and tried to enter the command again but the same error occurred ... (WinSCP and Putty are both running as admin)
 
Last edited:

Don Daniello

/root
Staff member
Administrator
Joined
Apr 11, 2008
Messages
3,506
Best answers
15
Reaction score
895
Location
Proland
I did enter LINUX and it gave me that error. I guess that line was not needed , I just removed it. Seems to work fine.
Code:
LINUX
and
Code:
'LINUX'
are not the same thing.

I do in fact have an exe.
So you shouldn't be trying to run the Linux version we provided if it's different. Or maybe you deleted that too.

IYesterday i deleted all the website and server files and added clean ones from backup. Today I added clean exe and .dll files from backup(after attempting to run a few times), and looked through very page of Sigu Support on Otland. It looks like there is a wide variety of things that can go wrong.
I found someone saying to do this "configure tfs version in .tfs-version file. " but maybe it's outdated. It was on the fifth page. I can't find that file anywhere.
That is from many years ago. We don't use the .tfs-version file anymore, you won't find it.

II ran TFS in foreground
/home/otsmanager/forgottenserver/build/tfs.exe - or ./forgottenserver/build/tfs.exe
(i believe this is the right way got it from here Solved - Problems running my OTS 8.6) and it came back
-bash: /home/otsmanager/forgottenserver/build/tfs.exe: Permission denied[/quote]
You can't run a Windows EXE on Linux like this. Our wiki has answers to all your problems. How to run your EXE is explained here: DevelopersPL/otshosting-provisioning

II then deleted IIS_IUSRS permissions on the server folder(see above), moved that folder again to the host, and tried to enter the command again but the same error occurred ... (WinSCP and Putty are both running as admin)
You can't remove IIS_IUSRS permissions on a Linux box, which is what we provide. You probably did this on your machine, which makes no difference at all.

As a free non-profit server we sponsor, I can't fix those issues for you because the free offer does not include Support.
 
OP
wickedd

wickedd

Intermediate OT User
Joined
Oct 14, 2011
Messages
244
Best answers
1
Reaction score
21
Location
US
I did try to run wine before, did I corrupt something?
now it says no driver could be loaded
 
Top