• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Solved Myaac, Cannot connect to MySQL database. OTX 2. - 7.72

psilocybusmaxim

New Member
Joined
Oct 12, 2020
Messages
45
Solutions
1
Reaction score
4
Location
Detroit, MI
So I did a few fix's before bed on my web site and a few npc's, I woke up to this error, servers working fine though.
I did a backup last night but the backups all fudged up to, maybe that had something to do with it IDK.
Any help would be appreciated, Thanks for looking.

PHP:
ERROR: Cannot connect to MySQL database.
Possible reasons:
MySQL is not configured propertly in config.lua.
MySQL server is not running.
SQLSTATE[HY000] [1049] Unknown database 'ots'


Backtrace:

#0 C:\xampp\htdocs\system\init.php(127): require_once()
#1 C:\xampp\htdocs\index.php(171): require_once('C:\\xampp\\htdocs...')
#2 {main}

My config.lua hasn't changed so I don't think that's the problem. Not sure though.
Post automatically merged:

The problem was I changed my old server file name, and I didn't know my site was still using my old OT folder. I feel like I keep making dumb mistakes after taking a break for a month sorry guys.
 
Last edited:
Solution
So, solver? =) Mark as solver then please.

Couldn't add solved with a merged post, sorry btw slaw you rock! Love your code.

The problem was I changed my old server file name, and I didn't know my site was still using my old OT folder. I feel like I keep making dumb mistakes after taking a break for a month sorry guys.
OP
OP
psilocybusmaxim

psilocybusmaxim

New Member
Joined
Oct 12, 2020
Messages
45
Solutions
1
Reaction score
4
Location
Detroit, MI
So, solver? =) Mark as solver then please.

Couldn't add solved with a merged post, sorry btw slaw you rock! Love your code.

The problem was I changed my old server file name, and I didn't know my site was still using my old OT folder. I feel like I keep making dumb mistakes after taking a break for a month sorry guys.
 
Solution
Top