[MyAAC][Plugin][Template] Oni

Onimusha

Intermediate OT User
Joined
Dec 6, 2008
Messages
223
Reaction score
124
GitHub
eratsu
NOTE: This will work only with MyAAC version 0.4.3 and higher. On older version, some bugs will show up.

Please report bugs in this thread.

Installation:

Go to Admin Panel, select 'Plugins', and then select myaac-oni-template.zip and click upload. That's all!

Configuration:
In config.local.php set:
Code:
$config['template'] = 'oni';

Config Discord:
Open your site > templates > oni > index.php
Ctrl+F and search by discord and edit the iframe line.


Screenshots:
onitemplate.png


Changelog:
1.0: Template release;
1.1: Fixed the table and input colors, the page load animation was removed;

Download:
 

Attachments

  • myaac-oni-template.zip
    944.9 KB · Views: 84 · VirusTotal
Last edited:

slaw

Developer
Joined
Aug 27, 2007
Messages
3,259
Solutions
96
Reaction score
751
Location
Germany
GitHub
slawkens
Hello!

Thanks for a nice job on this!

However, there is one problem with your upload.

This plugin cannot be installed:
1609753686081.png

You need to add folder plugins into your zip and there oni-template.json, look how its made here:


So your end folder-structure should look like this:
Code:
plugins/
    oni-template.json
templates/
    oni/
        config.php
        index.php
        rest-of-the-files-here

After this, you can send that folders (plugins, templates) to the .zip file like this:
You select both folder with CTRL and right click, then choose "Send to" -> ZIP Archive
1609754037986.png


This way you create an installable .zip package that can be uploaded to MyAAC admin panel.

Also, on Discord you asked about newses not displaying correctly, and in your upload I don't see news.html.twig, is it missing?

Regards,
 

slaw

Developer
Joined
Aug 27, 2007
Messages
3,259
Solutions
96
Reaction score
751
Location
Germany
GitHub
slawkens
If anyone like me doesn't like the animation on page load:

Replace in style.css:
Code:
* {
  margin: 0;
  -webkit-transition: all 1s ease;
  -moz-transition: all 1s ease;
  -ms-transition: all 1s ease;
  -o-transition: all 1s ease;
  transition: all 1s ease;
}

*:hover {
  -webkit-transition: all 1s ease;
  -moz-transition: all 1s ease;
  -ms-transition: all 1s ease;
  -o-transition: all 1s ease;
  transition: all 1s ease;
}

With just:
Code:
* {
  margin: 0;
}
 

Vinicius Chaves

New Member
Joined
Oct 30, 2018
Messages
22
Solutions
2
Reaction score
3
I am trying to set up my discord but it keeps "0" all the time ): even getting enabled the widget on discord's serve setup
 
Top