• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Need help setting up local server Mehah/TFS 1.4 on Windows


New Member
Jun 1, 2024
Reaction score
Objective: A local server running on WIndows 11 which uses the Mehah client.

Level of expertise: 2/10 (very, very limited)

Obstacles: Too many, but to name a few.
1. Succesfully installed Mehah client, it can open, but when asked for a server I'm clueless to what the next step is. I keep getting login error, connection failed 11001.
2. When installing RME and trying to set it up for client 11, it lags and bugs like hell. Unsure on what downloads and settings to use.
3. Tried to install tfs instead, but ran into a million bugs and errors on my way.

Steps taken:
  • Created folder: D:\OT_building\tfs
  • Downloaded vcpkg package using the terminal with admin rights
✓ git clone GitHub - microsoft/vcpkg: C++ Library Manager for Windows, Linux, and MacOS (https://github.com/Microsoft/vcpkg)
✓ cd vcpkg
✓ .\bootstrap-vcpkg.bat
✓ .\vcpkg integrate install

  • Downloaded forgottenserver 1.4 source code, copied files to D:\OT_building\tfs\tfs14
  • Opened .vcxproj in VS 22, release x64 failed when building
× 1>The vcpkg manifest was disabled, but we found a manifest file in D:\OT_building\tfs\. You may want to enable vcpkg manifests in your properties page or pass /p:VcpkgEnableManifest=true to the msbuild invocation.
1>D:\OT_building\tfs\src\otpch.h(26,10): fatal error C1083: Cannot open include file: 'boost/asio.hpp': No such file or directory
1>Done building project "theforgottenserver.vcxproj" -- FAILED.

- Entered in terminal with admin rights: .\vcpkg install --triplet x64-windows boost-iostreams boost-asio boost-system boost-filesystem boost-variant boost-lockfree luajit libmariadb pugixml cryptopp fmt
× error: In manifest mode, vcpkg install does not support individual package arguments.
To install additional packages, edit vcpkg.json and then run vcpkg install without any package arguments.
See Manifest mode (https://learn.microsoft.com/vcpkg/users/manifests) for more information.

- Looking for a .json file, can't find one. Tried Googling, but more mambo jambo which didn't help.

- As nothing worked, I tried this in my terminal: .\vcpkg install, didn't change the situation.

Summary: As I didn't get Mehah to work, I tried the forgotten server 1.4 (I also tried the master branch, didn't work either). I don't like the mapping of the .dat and .spr in the older client versions on RME, I prefer the correctly mapped version with more brushes, borders, etc. I would like to play around creating modules for the Mehah client for myself, as I do know some basic .lua and CSS. I never touched C or C++, and frankly have no interest in learning it either. I did get Uniserver to work with ZNote using a tfs .sql and creating an account and a character succesfully. However, with Mehah I couldn't find a .sql, so that's why I proceeded with tfs.

Conclusion: The most basic tutorials on the internet simply do not work for some reason or expect people to know how to proceed next. Like I said, absolute, utter noob here. Maybe you're thinking, so go learn this stuff, or if you're such a noob, stop trying, but I like to learn through doing stuff. Meaning I need an environment (locally) to play around, tinker, try, fail, fail more and learn. Is there anyone out there who can tell me what I'm doing wrong and why it doesn't seem to work? Preferably I'd like to use the Mehah client and not the older forgottenserver clients.

Would love to hear from someone! Who wants to adopt this noob? :eek: