• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

TFS 1.X+ OSX 10.14 - LLDB / GDB - unable to find symbols

Snavy

Bakasta
Senator
Joined
Apr 1, 2012
Messages
1,243
Solutions
71
Reaction score
570
Location
Hell
Using TFS 1.3

I have made some modifications in the sources and am facing segmentation fault 11 crash.
I tried debugging with lldb ( it wasn't compiled with -g flag )
Code:
(lldb) target create tfs
Current executable set to 'tfs' (x86_64).
(lldb) run

...
... TFS log here
...

Process 27477 stopped
* thread #2, stop reason = EXC_BAD_ACCESS (code=1, address=0x2d)
    frame #0: 0x000000000048c280 libluajit-5.1.dylib`___lldb_unnamed_symbol272$$libluajit-5.1.dylib + 96
libluajit-5.1.dylib`___lldb_unnamed_symbol272$$libluajit-5.1.dylib:
->  0x48c280 <+96>:  movl   0xc(%rax), %edx
    0x48c283 <+99>:  cmpl   %ebp, %edx
    0x48c285 <+101>: jne    0x48c2b0                  ; <+144>
    0x48c287 <+103>: cmpl   $-0x4, %ebp
Target 0: (tfs) stopped.
This didn't seem clear enough and I went on to compile with -g flag but even then there was no human-readable debug info.
All I get is lowlevel info.


I have also tried with GDB, but no luck with that one either
Code:
warning: `/tmp/lto.o': can't open to read symbols: No such file or directory.
warning: `/tmp/lto.o': can't open to read symbols: No such file or directory.
(No debugging symbols found in ./tfs)



I added the -g flag here, in CMakeLists.txt:
Code:
if (NOT WIN32)
    add_compile_options(-Wall -Werror -pipe -fvisibility=hidden -g)
endif ()

What should I try next?



EDIT (02:09 AM):
Did some research, came across this post:

Compiled with -g -O0, executed image lookup -vn <theCPPFunctionNameHere>
and the output has no CompileUnit and according to the answer on the SO-post:
If the output of that command includes a CompileUnit, then the .o file containing that function has debug information, otherwise, not.

pepothink.pnghmm, what to do?
 
Last edited:
OP
OP
Snavy

Snavy

Bakasta
Senator
Joined
Apr 1, 2012
Messages
1,243
Solutions
71
Reaction score
570
Location
Hell

What do you mean?

I've mentioned that I tried gdb :confused:
warning: `/tmp/lto.o': can't open to read symbols: No such file or directory.
warning: `/tmp/lto.o': can't open to read symbols: No such file or directory.
(No debugging symbols found in ./tfs)
 
Last edited:
Top