• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

OTClient PROBLEM INSTALLING OTCLIENT LIBRARIES

johnsamir

Active Member
Joined
Oct 13, 2009
Messages
232
Solutions
1
Reaction score
35
Location
Nowhere
Hello i want to compile otclient, but im having troubles whn installing the libraries
Lua:
aCMake Error at scripts/cmake/vcpkg_execute_required_process.cmake:105 (message):
    Command failed: D:/vcpkg/installed/x64-windows/tools/boost-build/b2.exe --stagedir=D:/vcpkg/buildtrees/boost-thread/x86-windows-rel/stage --build-dir=D:/vcpkg/buildtrees/boost-thread/x86-windows-rel --user-config=D:/vcpkg/buildtrees/boost-thread/x86-windows-rel/user-config.jam /boost/thread//boost_thread -j4 --debug-configuration --debug-building --debug-generators --disable-icu --ignore-site-config --hash -q -sZLIB_INCLUDE=D:/vcpkg/installed/x86-windows/include -sBZIP2_INCLUDE=D:/vcpkg/installed/x86-windows/include -sLZMA_INCLUDE=D:/vcpkg/installed/x86-windows/include -sZSTD_INCLUDE=D:/vcpkg/installed/x86-windows/include threading=multi threadapi=win32 runtime-link=shared link=shared address-model=32 architecture=x86 asmflags=/safeseh -sZLIB_BINARY=zlib -sZLIB_LIBPATH=D:/vcpkg/installed/x86-windows/lib -sBZIP2_BINARY=bz2 -sBZIP2_LIBPATH=D:/vcpkg/installed/x86-windows/lib -sLZMA_BINARY=lzma -sLZMA_LIBPATH=D:/vcpkg/installed/x86-windows/lib -sZSTD_BINARY=zstd -sZSTD_LIBPATH=D:/vcpkg/installed/x86-windows/lib variant=release debug-symbols=on
    Working Directory: D:/vcpkg/buildtrees/boost-thread/src/ost-1.75.0-124a8e55a2.clean/build
    Error code: 1
    See logs for more information:
      D:\vcpkg\buildtrees\boost-thread\build-x86-windows-rel-out.log

Call Stack (most recent call first):
  installed/x64-windows/share/boost-build/boost-modular-build.cmake:332 (vcpkg_execute_required_process)
  ports/boost-thread/portfile.cmake:15 (boost_modular_build)
  scripts/ports.cmake:142 (include)


Error: Building package boost-thread:x86-windows failed with: BUILD_FAILED
Please ensure you're using the latest portfiles with `.\vcpkg update`, then
submit an issue at https://github.com/Microsoft/vcpkg/issues including:
  Package: boost-thread:x86-windows
  Vcpkg version: 2021-01-13-d67989bce1043b98092ac45996a8230a059a2d7e

Additionally, attach any relevant sections from the log files above.

D:\vcpkg>
what I'm doing wrong?
 
Top