• Vote in May Mapping Competition to select a winner!
  • There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Linux Problem with ubuntu

Exedras

New Member
Joined
Jun 1, 2009
Messages
11
Best answers
0
Reaction score
0
Hello guys, i'm trying to run my new server on ubuntu and i have some problems. I have installed mysql/php etc, but when i'm trying to run server i have a error
Code:
 error while loading shared libraries: libboost_filesystem.so.1.58.0: cannot open shared object file: No such file or directory
Can someone help me?
 
OP
E

Exedras

New Member
Joined
Jun 1, 2009
Messages
11
Best answers
0
Reaction score
0
When i have a compiled it from last time i have to do it again?
 

Pox

Member
Joined
Apr 28, 2020
Messages
31
Best answers
0
Reaction score
13
I would assume some library isn’t installed correctly or not at all.
I would start over from start
 

Kouki

New Member
Joined
Feb 5, 2016
Messages
28
Best answers
2
Reaction score
3
Just write in consol
Code:
sudo apt install libboost-filesystem-dev
but if you changed the machine and didn't compile the source on a new one, you may get libs errors.
If you get some errors, just install all libs and recompile as @Pox wrote :)
 

Lessaire

Omniscient Hypervisor
Premium User
Joined
Dec 29, 2009
Messages
1,241
Best answers
44
Reaction score
371
Location
Oregon
If you're wanting to compile Boost yourself, and you've updated your Ubuntu to 20.04, just stop now. It's FTBFS right now because of py3versions -vr not working. You'd waste a lot of time.
If you still really want to build it,
Bash:
cd ~/src
apt source boost1.71
cd boost1.71-1.71.0/debian/
sed 's|py3versions -vr|py3versions -vd|g' rules -i
cd ..
debuild

If you compiled a binary before and then upgraded your server from like from 16.04 LTS to 18.04 LTS or 20.04 LTS, you have to:
old distro: run ./configure again and make it again
new distro: nuke and pave the build folder cmake it again.
 
Top