Problem z nginx pobiera pliki zamiast wczytywać PHP

robert100

New Member
Joined
May 2, 2011
Messages
3
Reaction score
0
Witam mam taki problem ostatnio zaczalem sie bawic z VPS zaczym idzie chce postawić OTS. Po wgraniu strony wyskakuje mi nastepujacy błąd

Code:
setPrintQueries(true); // DATABASE END // LOGIN if(!ONLY_PAGE) include_once('./system/load.login.php'); // LOGIN END // COMPAT // some parts in that file can be blocked because of ONLY_PAGE constant include_once('./system/load.compat.php'); // COMPAT END // LOAD PAGE include_once('./system/load.page.php'); // LOAD PAGE END // LAYOUT // with ONLY_PAGE we return only page text, not layout if(!ONLY_PAGE) include_once('./system/load.layout.php'); else echo $main_content; // LAYOUT END
 

HjugO

Member
Joined
Feb 7, 2015
Messages
30
Reaction score
7
Witam mam taki problem ostatnio zaczalem sie bawic z VPS zaczym idzie chce postawić OTS. Po wgraniu strony wyskakuje mi nastepujacy błąd

Code:
setPrintQueries(true); // DATABASE END // LOGIN if(!ONLY_PAGE) include_once('./system/load.login.php'); // LOGIN END // COMPAT // some parts in that file can be blocked because of ONLY_PAGE constant include_once('./system/load.compat.php'); // COMPAT END // LOAD PAGE include_once('./system/load.page.php'); // LOAD PAGE END // LAYOUT // with ONLY_PAGE we return only page text, not layout if(!ONLY_PAGE) include_once('./system/load.layout.php'); else echo $main_content; // LAYOUT END
Pokaż config strony na z /etc/nginx/conf.d albo sites-available
 
OP
R

robert100

New Member
Joined
May 2, 2011
Messages
3
Reaction score
0
W folderze conf.d nic nie mam a defauld wygląda tak
Code:
server {
    listen 80 default_server;
    listen [::]:80 default_server;

    root /var/www/html;
    index index.php index.html index.htm index.nginx-debian.html;

    server_name 185.243.52.246;

    location / {
        try_files $uri $uri/ =404;
    }

    location ~ \.php$ {
        include snippets/fastcgi-php.conf;
        fastcgi_pass unix:/var/run/php5-fpm.sock;
    }

    location ~ /\.ht {
        deny all;
    }
}
 

HjugO

Member
Joined
Feb 7, 2015
Messages
30
Reaction score
7
W folderze conf.d nic nie mam a defauld wygląda tak
Code:
server {
    listen 80 default_server;
    listen [::]:80 default_server;

    root /var/www/html;
    index index.php index.html index.htm index.nginx-debian.html;

    server_name 185.243.52.246;

    location / {
        try_files $uri $uri/ =404;
    }

    location ~ \.php$ {
        include snippets/fastcgi-php.conf;
        fastcgi_pass unix:/var/run/php5-fpm.sock;
    }

    location ~ /\.ht {
        deny all;
    }
}
Czy na pewno masz php5-fpm? Sprawdź co zainstalowałeś na tym VPS
 
OP
R

robert100

New Member
Joined
May 2, 2011
Messages
3
Reaction score
0
Wszystko co mam zainstalowane
Code:
acl                                             install
adduser                                         install
apache2                                         install
apache2-bin                                     install
apache2-data                                    install
apache2-doc                                     install
apache2-mpm-prefork                             install
apache2-utils                                   install
apt                                             install
apt-utils                                       install
base-files                                      install
base-passwd                                     install
bash                                            install
bind9                                           install
bind9-host                                      install
bind9utils                                      install
binutils                                        install
bsd-mailx                                       install
bsdmainutils                                    install
bsdutils                                        install
bzip2                                           install
ca-certificates                                 install
cifs-utils                                      install
console-common                                  install
console-data                                    install
coreutils                                       install
cpio                                            install
cracklib-runtime                                install
cron                                            install
dash                                            install
db-util                                         install
db5.3-util                                      install
dbconfig-common                                 install
debconf                                         install
debconf-i18n                                    install
debconf-utils                                   install
debian-archive-keyring                          install
debianutils                                     install
dh-python                                       install
dialog                                          install
diffutils                                       install
dmsetup                                         install
dpkg                                            install
dselect                                         install
e2fslibs:amd64                                  install
ed                                              install
expat                                           install
fetchmail                                       install
file                                            install
findutils                                       install
finger                                          install
fontconfig                                      install
fontconfig-config                               install
fonts-dejavu                                    install
fonts-dejavu-core                               install
fonts-dejavu-extra                              install
fonts-freefont-ttf                              install
ftp                                             install
gawk                                            install
gcc-4.8-base:amd64                              install
gcc-4.9-base:amd64                              install
gettext                                         install
gettext-base                                    install
gnupg                                           install
gpgv                                            install
grep                                            install
groff-base                                      install
gzip                                            install
hostname                                        install
ifupdown                                        install
info                                            install
init-system-helpers                             install
initramfs-tools                                 install
initscripts                                     install
insserv                                         install
install-info                                    install
iproute2                                        install
iptables                                        install
iputils-arping                                  install
iputils-ping                                    install
iputils-tracepath                               install
isc-dhcp-client                                 install
isc-dhcp-common                                 install
javascript-common                               install
kbd                                             install
klibc-utils                                     install
kmod                                            install
ldap-utils                                      install
less                                            install
libacl1:amd64                                   install
libaio1:amd64                                   install
libapparmor1:amd64                              install
libapr1:amd64                                   install
libaprutil1:amd64                               install
libaprutil1-dbd-sqlite3:amd64                   install
libaprutil1-ldap:amd64                          install
libapt-inst1.5:amd64                            install
libapt-pkg4.12:amd64                            install
libasn1-8-heimdal:amd64                         install
libasprintf0c2:amd64                            install
libattr1:amd64                                  install
libaudit-common                                 install
libaudit1:amd64                                 install
libavahi-client3:amd64                          install
libavahi-common-data:amd64                      install
libavahi-common3:amd64                          install
libbind9-90                                     install
libblkid1:amd64                                 install
libbsd0:amd64                                   install
libbz2-1.0:amd64                                install
libc-bin                                        install
libc6:amd64                                     install
libcap-ng0:amd64                                install
libcap2:amd64                                   install
libcap2-bin                                     install
libcomerr2:amd64                                install
libcrack2:amd64                                 install
libcroco3:amd64                                 install
libcryptsetup4:amd64                            install
libcups2:amd64                                  install
libdb5.3:amd64                                  install
libdbd-mysql-perl                               install
libdbi-perl                                     install
libdbus-1-3:amd64                               install
libdebconfclient0:amd64                         install
libdevmapper1.02.1:amd64                        install
libdns-export100                                install
libdns100                                       install
libedit2:amd64                                  install
libestr0                                        install
libexpat1:amd64                                 install
libffi6:amd64                                   install
libfile-copy-recursive-perl                     install
libfontconfig1:amd64                            install
libfreetype6:amd64                              install
libgcc1:amd64                                   install
libgcrypt20:amd64                               install
libgd3:amd64                                    install
libgdbm3:amd64                                  install
libgeoip1:amd64                                 install
libglib2.0-0:amd64                              install
libgmp10:amd64                                  install
libgnutls-deb0-28:amd64                         install
libgnutls-openssl27:amd64                       install
libgomp1:amd64                                  install
libgpg-error0:amd64                             install
libgpm2:amd64                                   install
libgssapi-krb5-2:amd64                          install
libhcrypto4-heimdal:amd64                       install
libhdb9-heimdal:amd64                           install
libheimbase1-heimdal:amd64                      install
libhogweed2:amd64                               install
libhtml-template-perl                           install
libhx509-5-heimdal:amd64                        install
libicu52:amd64                                  install
libidn11:amd64                                  install
libirs-export91                                 install
libisc-export95                                 install
libisc95                                        install
libisccc90                                      install
libisccfg-export90                              install
libisccfg90                                     install
libjbig0:amd64                                  install
libjpeg62-turbo:amd64                           install
libjs-jquery                                    install
libjs-sphinxdoc                                 install
libjs-underscore                                install
libjson-c2:amd64                                install
libk5crypto3:amd64                              install
libkeyutils1:amd64                              install
libklibc                                        install
libkmod2:amd64                                  install
libkrb5-26-heimdal:amd64                        install
libkrb5-3:amd64                                 install
libkrb5support0:amd64                           install
libldap-2.4-2:amd64                             install
libldb1:amd64                                   install
liblocale-gettext-perl                          install
liblockfile-bin                                 install
liblockfile1:amd64                              install
liblogging-stdlog0:amd64                        install
liblognorm1:amd64                               install
libltdl7:amd64                                  install
liblua5.1-0:amd64                               install
liblwres90                                      install
liblzma5:amd64                                  install
libmagic1:amd64                                 install
libmcrypt4                                      install
libmhash2:amd64                                 install
libmount1:amd64                                 install
libmpdec2:amd64                                 install
libmpfr4:amd64                                  install
libmysqlclient18:amd64                          install
libncurses5:amd64                               install
libncursesw5:amd64                              install
libnettle4:amd64                                install
libnfnetlink0:amd64                             install
libnih-dbus1                                    install
libnih1                                         install
libnl-3-200:amd64                               install
libnl-genl-3-200:amd64                          install
libntdb1:amd64                                  install
libodbc1:amd64                                  install
libonig2:amd64                                  install
libp11-kit0:amd64                               install
libpam-modules:amd64                            install
libpam-modules-bin                              install
libpam-runtime                                  install
libpam0g:amd64                                  install
libpaper1:amd64                                 install
libpcap0.8:amd64                                install
libpci3:amd64                                   install
libpcre3:amd64                                  install
libperl4-corelibs-perl                          install
libperl5.20                                     install
libpipeline1:amd64                              install
libpng12-0:amd64                                install
libpopt0:amd64                                  install
libprocps3:amd64                                install
libpsl0:amd64                                   install
libpython-stdlib:amd64                          install
libpython2.7:amd64                              install
libpython2.7-minimal:amd64                      install
libpython2.7-stdlib:amd64                       install
libpython3-stdlib:amd64                         install
libpython3.4-minimal:amd64                      install
libpython3.4-stdlib:amd64                       install
libqdbm14                                       install
libreadline6:amd64                              install
libroken18-heimdal:amd64                        install
libsasl2-2:amd64                                install
libsasl2-modules-db:amd64                       install
libselinux1:amd64                               install
libsemanage-common                              install
libsemanage1:amd64                              install
libsensors4:amd64                               install
libsepol1:amd64                                 install
libsigsegv2:amd64                               install
libslang2:amd64                                 install
libsmartcols1:amd64                             install
libsnmp-base                                    install
libsnmp30:amd64                                 install
libsqlite3-0:amd64                              install
libssl1.0.0:amd64                               install
libstdc++6:amd64                                install
libsystemd0:amd64                               install
libtalloc2:amd64                                install
libtasn1-6:amd64                                install
libtdb1:amd64                                   install
libterm-readkey-perl                            install
libtevent0:amd64                                install
libtext-charwidth-perl                          install
libtext-iconv-perl                              install
libtext-wrapi18n-perl                           install
libtiff5:amd64                                  install
libtinfo5:amd64                                 install
libtirpc1:amd64                                 install
libudev1:amd64                                  install
libunistring0:amd64                             install
libusb-0.1-4:amd64                              install
libustr-1.0-1:amd64                             install
libuuid1:amd64                                  install
libvpx1:amd64                                   install
libwbclient0:amd64                              install
libwind0-heimdal:amd64                          install
libwrap0:amd64                                  install
libx11-6:amd64                                  install
libx11-data                                     install
libxau6:amd64                                   install
libxcb1:amd64                                   install
libxdmcp6:amd64                                 install
libxml2:amd64                                   install
libxpm4:amd64                                   install
libxslt1.1:amd64                                install
libxtables10                                    install
locales                                         install
login                                           install
logrotate                                       install
lsb-base                                        install
lsb-release                                     install
lsof                                            install
lynx                                            install
lynx-cur                                        install
lzma                                            install
m4                                              install
make                                            install
makedev                                         install
man-db                                          install
manpages                                        install
mcrypt                                          install
memtester                                       install
mime-support                                    install
mktemp                                          install
mlocate                                         install
module-init-tools                               install
mount                                           install
mtools                                          install
multiarch-support                               install
mysql-client-5.5                                install
mysql-common                                    install
mysql-server                                    install
mysql-server-5.5                                install
mysql-server-core-5.5                           install
ncurses-base                                    install
ncurses-bin                                     install
ncurses-term                                    install
net-tools                                       install
netbase                                         install
nginx                                           install
nginx-common                                    install
nginx-full                                      install
odbcinst                                        install
odbcinst1debian2:amd64                          install
openssh-blacklist                               install
openssh-client                                  install
openssh-server                                  install
openssh-sftp-server                             install
openssl                                         install
openssl-blacklist                               install
passwd                                          install
patch                                           install
perl                                            install
perl-base                                       install
perl-modules                                    install
php-gettext                                     install
php-tcpdf                                       install
php5                                            install
php5-cli                                        install
php5-common                                     install
php5-fpm                                        install
php5-gd                                         install
php5-json                                       install
php5-mcrypt                                     install
php5-mysql                                      install
php5-readline                                   install
phpmyadmin                                      install
postfix                                         install
procinfo                                        install
procmail                                        install
procps                                          install
psmisc                                          install
psutils                                         install
pwgen                                           install
python                                          install
python-crypto                                   install
python-dnspython                                install
python-ldb                                      install
python-minimal                                  install
python-ntdb                                     install
python-samba                                    install
python-talloc                                   install
python-tdb                                      install
python2.7                                       install
python2.7-minimal                               install
python3                                         install
python3-minimal                                 install
python3.4                                       install
python3.4-minimal                               install
quota                                           install
readline-common                                 install
rpcbind                                         install
rsync                                           install
rsyslog                                         install
samba                                           install
samba-common                                    install
samba-common-bin                                install
samba-dsdb-modules                              install
samba-libs:amd64                                install
sasl2-bin                                       install
screen                                          install
sed                                             install
sensible-utils                                  install
sharutils                                       install
snmp                                            install
ssl-cert                                        install
startpar                                        install
sudo                                            install
syslinux                                        install
systemd                                         install
systemd-sysv                                    install
sysv-rc                                         install
sysvinit-utils                                  install
tar                                             install
tcpdump                                         install
tcsh                                            install
tdb-tools                                       install
telnet                                          install
tofrodos                                        install
traceroute                                      install
ttf-dejavu                                      install
ttf-dejavu-core                                 install
ttf-dejavu-extra                                install
ttf-freefont                                    install
tzdata                                          install
ucf                                             install
udev                                            install
unixodbc                                        install
unzip                                           install
update-inetd                                    install
util-linux                                      install
uuid-runtime                                    install
vim                                             install
vim-common                                      install
vim-runtime                                     install
wget                                            install
whois                                           install
wide-dhcpv6-client                              install
xinetd                                          install
xz-utils                                        install
zlib1g:amd64                                    install
 
Top