• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

OTClient Set FPS limit to OTClient

ralke

(҂ ͠❛ ෴ ͡❛)ᕤ
Joined
Dec 17, 2011
Messages
871
Solutions
19
Reaction score
409
Location
Santiago - Chile
Hi! I successfully compiled mehah OTClient mehah/otclient (https://github.com/mehah/otclient), and tested it on localhost. All is running excelent, I can't say nothing, it is just amazing. But I have too much FPS rate, I run it on 3420 FPS and my PC start making a strange noise, that worries me. My question is, where in the sources I can set a limit FPS, when I set it to MAX, and what value you guys consider is good to set (example: 400FPS)? the previous value to max (200FPS) seems good to a fluid gameplay but is too slow after seeing the 3k FPS. Attached an image to explain.
FPS.png

Regards!
Post automatically merged:

#Fixed
Solution was modules/client_options/options.lua
Code:
    local text, v = value, value
    if value <= 0 or value >= 201 then text = 'max' v = 400 end
    graphicsPanel:getChildById('backgroundFrameRateLabel'):setText(tr('Game framerate limit: %s', text))
    g_app.setBackgroundPaneMaxFps(v)

Anyways i'm still intrested in where FPS are located in sources and which ammount is recommended. Regards!
Test on 250 FPS seems to force GPU (rtx 1060) too much, at the moment I set max to 230 FPS.
gputest.png
 
Last edited:
Solution
Use vsync
It was enabled when tested, but after testing FPS values one by one, the best result for me was limit at 230FPS:
modules\client_options\options.lua
Code:
    local text, v = value, value
    if value <= 0 or value >= 201 then text = 'max' v = 230 end
    graphicsPanel:getChildById('backgroundFrameRateLabel'):setText(tr('Game framerate limit: %s', text))
    g_app.setBackgroundPaneMaxFps(v)

I'll mark the thread as solved to get it closed, thanks for responding @Nekiro
Regards!
OP
ralke

ralke

(҂ ͠❛ ෴ ͡❛)ᕤ
Joined
Dec 17, 2011
Messages
871
Solutions
19
Reaction score
409
Location
Santiago - Chile
Use vsync
It was enabled when tested, but after testing FPS values one by one, the best result for me was limit at 230FPS:
modules\client_options\options.lua
Code:
    local text, v = value, value
    if value <= 0 or value >= 201 then text = 'max' v = 230 end
    graphicsPanel:getChildById('backgroundFrameRateLabel'):setText(tr('Game framerate limit: %s', text))
    g_app.setBackgroundPaneMaxFps(v)

I'll mark the thread as solved to get it closed, thanks for responding @Nekiro
Regards!
 
Solution

Silba

is stephany, the josh wife
Premium User
Joined
Aug 22, 2013
Messages
340
Solutions
3
Reaction score
244
You should be setting your fps to the same refresh rate(or a multiple of) as your monitor for best results, or as nekro said use vsync. If vsync was enabled then it wasn't working. Vsync locks the fps to your refresh rate even if fps limit set to max.
 
Top