• Vote in May Mapping Competition to select a winner!
  • There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Setting up my website to support mobile devices

Yourdailyrandom

Vajamba
Joined
Dec 23, 2014
Messages
4
Best answers
0
Reaction score
1
Location
Sweden, Dalarna
It has been long since i last visited otland. I used to go under the name Gatupojk, and if i can recall correctly i think i got it changed to ragequit. Maybe someone remembers me(or not :D).
What i want help with today is not related with open tibia and i hope its okay i ask for help here anyway :)

I'm setting up an online store for a friends company.
The website must have support for mobile devices, a simple layout for mobile devices. So i would like to know all the steps in redirecting people on mobile devices to m.domain.com, setting up the folders etc. I pretty much have everything set up except that.
I used dreamweaver for a while & fluid grids but i found that somewhat annoying to work with..

Thanks!


Edit;
I forgot to say that i already found how to redirect mobile devices to m.domain.com, but i dont the rest. Like where i put the mobile website folders and how i link it together with m.domain.com
 
Last edited:
OP
Yourdailyrandom

Yourdailyrandom

Vajamba
Joined
Dec 23, 2014
Messages
4
Best answers
0
Reaction score
1
Location
Sweden, Dalarna
well im doing something wrong, thats for sure! I just dont know what.
I got myself a wildcard dns at dyndns so now m.domain.com works but it seems to direct me to my main folder, not my mobile folder.
This is how i set it up in httpd-vhosts.conf(domain.com is not the real adress ofc :p)
Code:
NameVirtualHost *:80

<VirtualHost *:80>
    ServerName domain.com
    DocumentRoot ${US_ROOTF_WWW}/main
</VirtualHost>

<VirtualHost *:80>
    ServerName m.domain.com
    DocumentRoot ${US_ROOTF_WWW}/mobile
<VirtualHost>
i also uncommented this line in httpd.conf:
Code:
Include conf/extra/httpd-vhosts.conf
 
OP
Yourdailyrandom

Yourdailyrandom

Vajamba
Joined
Dec 23, 2014
Messages
4
Best answers
0
Reaction score
1
Location
Sweden, Dalarna
Yea, several times :s


edit;
I just realized i never closed <virtualhost>......... forgot the forward slash...
Searched through the error log and found the error :p
Now its working! Thanks for the help
 
Last edited:
Top