• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

trying to start my real map otserver

lilzombie

New Member
Joined
Dec 6, 2020
Messages
3
Reaction score
0
GitHub
hejkolka
Fatal error: Declaration of Database::query($statement) must be compatible wit

PDO::query(string $query, ?int $fetchMode = null, mixed ...$fetchModeArgs) in C:\xampp\htdocs\classes\database.php on line 184

what do i do
 
OP
L

lilzombie

New Member
Joined
Dec 6, 2020
Messages
3
Reaction score
0
GitHub
hejkolka
yeah every time i try to run the server i get this error message and I cant connect to the website, there fore I cant create or log in to an account etc.
 

zirra

Member
Joined
Jun 11, 2009
Messages
343
Solutions
1
Reaction score
7
Location
Arizona, Usa
I ran into the same issue, I copied "string $query, ?int $fetchMode = null, mixed ...$fetchModeArgs" and pasted in place of "$statement". Got me past that, but into another error xD
 

Discovery

Developing myself
Joined
Apr 16, 2010
Messages
559
Solutions
11
Reaction score
250
Location
Neverland
What?

You're trying to start a real map otserver, but it's a PHP error haha

source.gif


What website you downloaded?
 

zirra

Member
Joined
Jun 11, 2009
Messages
343
Solutions
1
Reaction score
7
Location
Arizona, Usa
Fatal error: Declaration of Database::query($statement) must be compatible wit

PDO::query(string $query, ?int $fetchMode = null, mixed ...$fetchModeArgs) in C:\xampp\htdocs\classes\database.php on line 184

what do i do
Sharinn was right, you need to download the correct Xampp version. for me it was 7.3
 
Top