• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Compiling Windows 10, compiling tfs 1.3

Xikini

I whore myself out for likes
Support Team
Joined
Nov 17, 2010
Messages
4,741
Solutions
262
Reaction score
2,828
Okay I thought this was going to be easy but.. holy

I'm following this tutorial, but literally stuck on the second step


Download/install Visual Studio 2019 Community (compiler)

After downloading.. during setup there's like 17 different workloads and like 100+ individual components.

What am I supposed to install? Because nothing says 'compiler'..

I'd install them all.. but I don't have that much diskspace. lmao

Untitled.png
Post automatically merged:

Well, looking at other people posting issues, I think I only need to install 'Desktop development with C++'

Here's hoping it works. xD
Post automatically merged:

Alright, so I think it worked properly?

Some additional things I did..

I downloaded the source code into a different folder instead of into the vcpkg directory

I couldn't get the libraries installed on step 4, got some weird error.
Had to add ./ in front of the rest of the copy-paste.
Seems to have worked? 🤷‍♀️

and when trying to compile.. I was missing some sort of lua.hpp file..

Basically had to go through a rabbit hole to fix this lmao.

Idk what the issue was..

But I went

Project -> Properties -> C/C++ -> General -> (first line, Additional Include Directories) Clicked on the box beside it, and like.. reconfirmed the directory that was already there? idk
The directory was C:\vcpkg\packages\luajit_x64-windows\include

and then everything just magically worked and build succeeded.

I guess it's compiled.. but no idea wtf to do now.

Honestly, I feel bad for every person who has to go through this.
 
Last edited:
Top