• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!
  • If you're using Gesior 2012 or MyAAC, please review this thread for information about a serious security vulnerability and a fix.

TFS 1.X+ Wrong Item id found

alejandro762

Member
Joined
Sep 6, 2021
Messages
120
Reaction score
20
Hello

I try today import an old map i created with remeres, on a Tfs 1.3 Otservbr,
All seems working in game perfectly.

I just found there four lines from console as Wrong Item id found, with unique id ( looked on rme there is no one , also on scripts )
1740 is a chest on rme and there is only 8 chests on map with 0 on each uid and aid.
Lines are located after Signs so i try change ' startup folder ' , but i got a loadluamapbook error.
I'm out of ideas if anyone would be how can we find this problem
thx in advance

446sqd4q6s.png
 
Solution
It's reported by some otservbr Lua code that adds UID/AID to items on map. AIDs/UIDs are not on map, they are in Lua now.

They are configured in Lua: position, UID, itemid etc.
It expects that item with given ID will be on map on given position. It tries to find it and add UID/AID to it, but it cannot, because item is not there.
Problem with UID 6500 is there:
Lua:
[6050] = {
    itemId = 2472,
    itemPos = {x = 33039, y = 32171, z = 9},
    reward = {{3053, 1}},
    storage = Storage.Quest.TimeRing.TimeRing
},
It looks like you got old config with ID 1740, on new otservbr (with new .otb) it's 2472. Probably on your map on position...

abdala ragab

Banned User
Joined
Aug 18, 2018
Messages
306
Solutions
10
Reaction score
273
Hello

I try today import an old map i created with remeres, on a Tfs 1.3 Otservbr,
All seems working in game perfectly.

I just found there four lines from console as Wrong Item id found, with unique id ( looked on rme there is no one , also on scripts )
1740 is a chest on rme and there is only 8 chests on map with 0 on each uid and aid.
Lines are located after Signs so i try change ' startup folder ' , but i got a loadluamapbook error.
I'm out of ideas if anyone would be how can we find this problem
thx in advance

View attachment 66990
These numbers can be
frequent
Check it out on the map+actions
 

Gesior.pl

Mega Noob&LOL 2012
Senator
Premium User
Joined
Sep 18, 2007
Messages
2,834
Solutions
92
Reaction score
2,984
Location
Poland
GitHub
gesior
It's reported by some otservbr Lua code that adds UID/AID to items on map. AIDs/UIDs are not on map, they are in Lua now.

They are configured in Lua: position, UID, itemid etc.
It expects that item with given ID will be on map on given position. It tries to find it and add UID/AID to it, but it cannot, because item is not there.
Problem with UID 6500 is there:
Lua:
[6050] = {
    itemId = 2472,
    itemPos = {x = 33039, y = 32171, z = 9},
    reward = {{3053, 1}},
    storage = Storage.Quest.TimeRing.TimeRing
},
It looks like you got old config with ID 1740, on new otservbr (with new .otb) it's 2472. Probably on your map on position x = 33039, y = 32171, z = 9 is item with ID 2472 and OTS expects 1740. Or you just removed chest 1740 from that position while editing and server still expects it to be there.
 
Last edited:
Solution
OP
OP
alejandro762

alejandro762

Member
Joined
Sep 6, 2021
Messages
120
Reaction score
20
It's reported by some otservbr Lua code that adds UID/AID to items on map. AIDs/UIDs are not on map, they are in Lua now.

They are configured in Lua: position, UID, itemid etc.
It expects that item with given ID will be on map on given position. It tries to find it and add UID/AID to it, but it cannot, because item is not there.
Problem with UID 6500 is there:
Lua:
[6050] = {
    itemId = 2472,
    itemPos = {x = 33039, y = 32171, z = 9},
    reward = {{3053, 1}},
    storage = Storage.Quest.TimeRing.TimeRing
},
It looks like you got old config with ID 1740, on new otservbr (with new .otb) it's 2472. Probably on your map on position x = 33039, y = 32171, z = 9 is item with ID 2472 and OTS expects 1740. Or you just removed box from that position while editing and server still expects it to be there.
Awesome.

Never i figure to go on this folder.
Problem was solved deleting lines on chest.lua ( because custom map ). Then door_key.lua about Wrong AID 5010 item id 6249. Storage Quest Knight.

Thanks you very much @Gesior.pl
 
Top