• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Solved Cannot edit "/etc/systemd/system/tfs.service"

Falazen

Premium User
Premium User
Joined
Feb 18, 2008
Messages
82
Reaction score
2
[solved]I am denied permission to edit this file while setting up a new executable path in tfs.service. Any way to get around this?

Cheers,
Falazen
Post automatically merged:

Solved with using "sudo mcedit /etc/systemd/system/tfs.service" in PuttY.[/solved]


New problem: [solved]

I've since edited Tfs.service to include the correct pathways, and have uploaded my files with WinSCP, but the server refuses to launch still. What am I missing here? Thanks in advance everyone
Solved with: DevelopersPL/otshosting-provisioning (https://github.com/DevelopersPL/otshosting-provisioning/wiki/How-to-run-TFS-OTServ-compiled-for-Windows)
Use those commands in PuTTY.[/solved]

New new problem:[solved]

I'm.. not really sure where to begin on this one. I followed the instructions on the link above, and when launching with "wineconsole tfs.exe", I get all of these errors. I recompiled the server so it was just a regular command window and nothing fancy. Any advice?

Not really sure what I did here. I simply changed the pathing after being unable to launch it manually with PuTTY, restarted the host, and it worked. I followed the instructions above starting with "set up service unit" using PuTTY. [/solved]
 

Attachments

Last edited:
Top