• Sign up for TFS Icon Competition! The prize includes Otland Premium time and a medal, as well as obviously taking part in TFS history.
  • There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Dos Attack.

Abdelmaksod

Active Member
Joined
Oct 26, 2018
Messages
67
Reaction score
36
i use don's free vps and i am getting dos attacks, any iptables i can add?
when someone logout he can't connect
they use old dos attack program named, loic, hoic, server attack by c4 and anonymouse dos
 
Solution
He is someone I know, I helped him through Teamviewer.
Just enabled UFW and then allowed port 22 for SSH connection and login/game ports then added limits to them to stop the DOS spamming.

M0ustafa

1337
Senator
Joined
Mar 4, 2017
Messages
2,453
Solutions
306
Reaction score
1,035
Location
Egypt
He is someone I know, I helped him through Teamviewer.
Just enabled UFW and then allowed port 22 for SSH connection and login/game ports then added limits to them to stop the DOS spamming.
 
Solution

DukeeH

Active Member
Joined
Dec 6, 2010
Messages
548
Solutions
3
Reaction score
37
He is someone I know, I helped him through Teamviewer.
Just enabled UFW and then allowed port 22 for SSH connection and login/game ports then added limits to them to stop the DOS spamming.
Could you post the commands for this?
I'm not suffering yet, but I think it's better to prevent.
 

Shadow_

Veteran OT User
Joined
Jun 2, 2018
Messages
811
Solutions
26
Reaction score
268
Location
Cairo, Egypt
Could you post the commands for this?
I'm not suffering yet, but I think it's better to prevent.
i'll assume you are using ubuntu so get started by allowing IPV6 cast this command
Lua:
sudo nano /etc/default/ufw
and make sure IPV6 = yes then cast this
Code:
sudo ufw allow ssh
and this
Code:
sudo ufw enable
if you want to allow more ports use this
Code:
sudo ufw allow 6000:6007/tcp
sudo ufw allow 6000:6007/udp
also you can use this link How To Set Up a Firewall with UFW on Ubuntu 18.04 | DigitalOcean (https://www.digitalocean.com/community/tutorials/how-to-set-up-a-firewall-with-ufw-on-ubuntu-18-04)
to limit the connection you can use UFW or iptables cast
Sass:
sudo nano /etc/ufw/before.rules
under this
Code:
# Don't delete these required lines, otherwise there will be errors
*filter
:ufw-before-input - [:]
:ufw-before-output - [:]
:ufw-before-forward - [:]
:ufw-not-local - [:]
# End of required lines
add this
Code:
# Limit to 10 concurrent connections on port 80 and 22 per IP
-A ufw-before-input -p tcp --syn --dport 80 -m connlimit --connlimit-above 10 -j DROP
-A ufw-before-input -p tcp --syn --dport 22 -m connlimit --connlimit-above 10 -j DROP
Code:
# Limit to 20 connections on port 80 and 22 per 2 seconds per IP
-A ufw-before-input -p tcp --dport 80 -i eth0 -m state --state NEW -m recent --set
-A ufw-before-input -p tcp --dport 80 -i eth0 -m state --state NEW -m recent --update --seconds 2 --hitcount 20 -j DROP
-A ufw-before-input -p tcp --dport 22 -i eth0 -m state --state NEW -m recent --set
-A ufw-before-input -p tcp --dport 22 -i eth0 -m state --state NEW -m recent --update --seconds 2 --hitcount 20 -j DROP
 
Top