Compiling Linux

Discussion in 'Support' started by Niebieski, Feb 22, 2011.

  1. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    I got that error when I compilling my server, what's wrong? What do you think?

     
  2. Natan Beckman

    Natan Beckman Active Member

    Joined:
    Aug 1, 2010
    Messages:
    541
    Likes Received:
    28
    Best Answers:
    0
    test
     
  3. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    Now that problem:

     
  4. Natan Beckman

    Natan Beckman Active Member

    Joined:
    Aug 1, 2010
    Messages:
    541
    Likes Received:
    28
    Best Answers:
    0
    test!
     
  5. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    Can you give me your sources.list? It'll be help to me.
     
  6. Natan Beckman

    Natan Beckman Active Member

    Joined:
    Aug 1, 2010
    Messages:
    541
    Likes Received:
    28
    Best Answers:
    0
    For ubuntu:

    apt-get update
    apt-get update
     
  7. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    I'll try to do it for a second :p
     
  8. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    Look at this:
     
  9. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    It's not work, still got the problem:

     
  10. Natan Beckman

    Natan Beckman Active Member

    Joined:
    Aug 1, 2010
    Messages:
    541
    Likes Received:
    28
    Best Answers:
    0
    You use Ubuntu ?

    apt-get update
    if error occurs try again
    apt-get update
    And see if I'm still with the error
     
  11. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    On ubuntu, I just can't make pico etc, I using Debian 5 Lenny
     
  12. Bosphorus

    Bosphorus New Member

    Joined:
    Oct 15, 2010
    Messages:
    139
    Likes Received:
    10
    Best Answers:
    0
    Use this source.list
    Code (Text):
    1.  
    2. deb http://www.backports.org/debian lenny-backports main contrib non-free
    3.  
    4.  
    5. # main sources
    6.  
    7. deb http://debian.intergenia.de/debian/ lenny main contrib non-free
    8. deb-src http://debian.intergenia.de/debian/ lenny main contrib non-free
    9.  
    10. # volatile
    11.  
    12. deb http://debian.intergenia.de/debian-volatile/ lenny/volatile main contrib non-free
    13. deb-src http://debian.intergenia.de/debian-volatile/ lenny/volatile main contrib non-free
    14.  
    15. # security
    16.  
    17. deb http://debian.intergenia.de/debian-security/ lenny/updates main contrib non-free
    18. deb-src http://debian.intergenia.de/debian-security/ lenny/updates main contrib non-free
    19.  
    20. # intergenia.de additional repositories
    21.  
    22. deb http://mirror.intergenia.de/packages/deb/ lenny dedicated
    23. deb-src http://mirror.intergenia.de/packages/deb/ lenny dedicated
    24.  
    Execute this commands.
    Code (Text):
    1.  
    2. apt-get update
    3. apt-get upgrade
    4.  
    Now this.
    Code (Text):
    1.  
    2. aptitude -y install mysql-server-5.1 build-essential pkg-config libboost-dev libgmp3-dev liblua5.1-0-dev libboost1.40-dev libboost-system1.40-dev libboost-filesystem1.40-dev libboost-date-time1.40-dev libboost-regex1.40-dev libboost-thread1.40-dev libgmp3-dev liblua5.1-0 liblua5.1-0-dev liblua50 liblua50-dev liblualib50 liblualib50-dev lua50 lua5.1 libsqlite0-dev libsqlite3-dev sqlite3 libmysql++-dev libmysqlclient-dev mysql-client-5.1 mysql-server-5.1 mysql-common libxml2-dev libxml++2.6-dev cpp gcc g++ make automake autoconf pkg-config subversion liblua5.1-sql-mysql-dev liblua5.1-sql-sqlite3-dev zlib1g-dev zlib1g libcrypto++-dev ccache
    3.  
    Cya
     
  13. Toor

    Toor Active Member

    Joined:
    Sep 11, 2008
    Messages:
    174
    Likes Received:
    91
    Best Answers:
    0
    Check if -lpthread is included in 'Makefile' in the LIBS section.
     
  14. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    I did it with your repo and look:
     
  15. Natan Beckman

    Natan Beckman Active Member

    Joined:
    Aug 1, 2010
    Messages:
    541
    Likes Received:
    28
    Best Answers:
    0
    apt-get update
    2x
    fixes the problem
     
  16. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    I did it, but it didn't help :p Maybe I should use other repo etc?
     
  17. Niebieski

    Niebieski tibianus.org

    Joined:
    Jan 29, 2010
    Messages:
    272
    Likes Received:
    8
    Best Answers:
    0
    Noone knows how to fix it?;<
     
  18. Shinmaru

    Shinmaru エロルアー Scripter!

    Joined:
    Aug 20, 2007
    Messages:
    1,988
    Likes Received:
    89
    Best Answers:
    0
    Natan post your sources.list but using
    Code (Text):
    1. [./code] with out the dot, if you post it in quote or with out it it will parse and change links.
     
    Last edited: Feb 22, 2011
  19. Natan Beckman

    Natan Beckman Active Member

    Joined:
    Aug 1, 2010
    Messages:
    541
    Likes Received:
    28
    Best Answers:
    0
    Niebieski do what the shinmaru spoke.

    Edit
    Shinmarua i use ubuntu no use debian.
    Niebieski post your source.list
     
    Last edited: Feb 22, 2011
  20. Toor

    Toor Active Member

    Joined:
    Sep 11, 2008
    Messages:
    174
    Likes Received:
    91
    Best Answers:
    0
    Do what I wrote, edit your Makefile.
     

Share This Page

Loading...