Massive ping variation (rev.3777)

sowber

Member
Joined
Sep 30, 2016
Messages
35
Best answers
0
Reaction score
0
Yo, i'm having a massive ping variation in my server. Basically when i move my character i got a lot of freezes, my ping goes from 200~ to 400~. Taking a look at otland's i found a lot of threads saying that i should check my datapack and look for faulty scripts. I did some tests, and i'm getting these freezes even with default data from tfs, wich makes me wonder if this rev is really stable.

Is there any possible diagnostic / solution for that? Or even a direction to go?

Distro: GitHub - Fir3element/3777
 

Don Daniello

/root
Staff member
Administrator
Joined
Apr 11, 2008
Messages
3,509
Best answers
15
Reaction score
911
Location
Proland
Just to rule out any possibility that there is a connection issue between you an the server, did you check how the latest TFS and default datapack (what we preinstall) work for you and what ping you have?
 
OP
sowber

sowber

Member
Joined
Sep 30, 2016
Messages
35
Best answers
0
Reaction score
0
gonna do this asap, will post results here then
 
OP
sowber

sowber

Member
Joined
Sep 30, 2016
Messages
35
Best answers
0
Reaction score
0
getting 'Request timed out.' when pinging my server, so idk how to measure it xd. i could check before with elfbot (not sure if it's precise)
 

Don Daniello

/root
Staff member
Administrator
Joined
Apr 11, 2008
Messages
3,509
Best answers
15
Reaction score
911
Location
Proland
ICMP is blocked on our servers so you can't ping it. You can connect with OTClient and it shows you game ping.
 
OP
sowber

sowber

Member
Joined
Sep 30, 2016
Messages
35
Best answers
0
Reaction score
0
hmm, never heard about it tbh, gonna do a little research on this, thanks.
 
Joined
Sep 23, 2015
Messages
95
Best answers
1
Reaction score
29
Location
127.0.0.1
I had the same problem when using Firewalls on Linux Mint. If your server is possibly being ran off a Wifi Network, some Linux distros aren't too fond of Wifi, and the ping thing happens. I've researched how to fix this for quite some time, and haven't found a solution. But when running on Wifi via Debian, I don't get the random 7.8k ping spike and "Request Timed Out". However, when running Wifi on Ubuntu, Linux Mint, Fedora, ElementaryOS, Arch and even Kali Linux I get the same ping problem. It could be that the server you're hosting on doesn't have the proper network drivers, but I seriously doubt that, and I would advise not to try to fix them yourself, because if you don't know Linux well, you'll more than likely get stuck with a good ol' Initramfs> prompt on boot, which is just gay.
 
Top