• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

Problem with saving items in house

nilaya

New Member
Joined
Dec 29, 2011
Messages
18
Reaction score
0
Hello!

I have a 7.72 server that me and some of my friends play on. It's based on OThire 0.0.3 and i haven't really gotten into serious trouble, until now.

Some houses on the server refuses to save the items on the floor etc. I made the correct house tiles in Remere's map editor, with the correct exit and tiles. But the server refuse to save the items i put on the floor in the house.

Some houses works perfect like it should. And i have no Lua errors on the specific houses that don't work.

This is the world-house.xml

Lua:
<?xml version="1.0"?>
<houses>
    <house name="House of " houseid="8" entryx="33203" entryy="31841" entryz="7" rent="0" townid="9" size="66" />
    <house name="House of Slimmy" houseid="9" entryx="33227" entryy="32447" entryz="7" rent="1" townid="7" size="31" />
    <house name="House of Us" houseid="10" entryx="33226" entryy="31876" entryz="7" rent="10" townid="9" size="328" />
    <house name="Unnamed House #11" houseid="11" entryx="33287" entryy="32000" entryz="7" rent="0" townid="9" size="51" />
    <house name="Unnamed House #12" houseid="12" entryx="33287" entryy="31994" entryz="7" rent="0" townid="9" size="45" />
    <house name="Unnamed House #13" houseid="13" entryx="33287" entryy="31988" entryz="7" rent="0" townid="9" size="45" />
    <house name="Unnamed House #15" houseid="15" entryx="33210" entryy="31841" entryz="7" rent="0" townid="9" size="150" />
    <house name="House of Mike" houseid="16" entryx="33231" entryy="31847" entryz="7" rent="0" townid="9" size="113" />
    <house name="Unnamed House #19" houseid="19" entryx="33228" entryy="31854" entryz="7" rent="0" townid="9" size="25" />
    <house name="House of Slim #20" houseid="20" entryx="33231" entryy="31861" entryz="7" rent="0" townid="9" size="123" />
    <house name="Knecken" houseid="21" entryx="33278" entryy="31980" entryz="7" rent="0" townid="9" size="52" />
</houses>

When i save/close the server i always use /save or /shutdownserver before i press the X in the commandpromt.

Like i said, some houses work and some aint.

What could be wrong ?

/Mike
 

BahamutxD

Jack of all trades, master of none
Joined
Jun 8, 2009
Messages
850
Solutions
18
Reaction score
432
Location
Spain
Have you tryed running a clean database just to see if you can reproduce?

Theres also some missing houses there - not sure if that could lead to issues though.
 
OP
N

nilaya

New Member
Joined
Dec 29, 2011
Messages
18
Reaction score
0
The missing houses is cause of me fiddeling with Remere's. Thing is SOME of new houses i make work instantly. And some dont.

If you look at the image below, the house in green works. But the one in red dont. Even if i delete the house in Remere's and make a new one with the same tiles etc.

house.jpg
And if i make another house in foe Thais, it works. The problem i had now was this house in Cormaya

house2.jpg
 

Alpha

Relentless
Premium User
Joined
Apr 3, 2011
Messages
629
Solutions
35
Reaction score
431
Location
South Korea
The missing houses is cause of me fiddeling with Remere's. Thing is SOME of new houses i make work instantly. And some dont.

If you look at the image below, the house in green works. But the one in red dont. Even if i delete the house in Remere's and make a new one with the same tiles etc.

View attachment 53454
And if i make another house in foe Thais, it works. The problem i had now was this house in Cormaya

View attachment 53455
Perhaps you forgot to set door id's?
 
Top