TFS Wont Start with no error after Compiling

mesosot

Premium User
Premium User
Joined
Aug 16, 2007
Messages
355
Best answers
0
Reaction score
5
after i compiled the server with no error on Release / win 64 i copy all vc14 folder component to the server files data etc ...

i try to start the theforgottenserver-x64.exe file it wont start or it just flash the CMD screen " black screen " and nothing to do
also i notices that the tfs.exe has no logo
1570812783476.png
 

Delusion

Divine Intellect
Support Team
Joined
Feb 14, 2015
Messages
5,220
Best answers
508
Reaction score
2,849
You need to set up a database and edit config.lua to connect to that database.
You can also view the error (in case it's not database) by opening CMD, typing cd "your_server_directory" and typing theforgottenserver-x64.exe.
 
OP
mesosot

mesosot

Premium User
Premium User
Joined
Aug 16, 2007
Messages
355
Best answers
0
Reaction score
5
You need to set up a database and edit config.lua to connect to that database.
You can also view the error (in case it's not database) by opening CMD, typing cd "your_server_directory" and typing theforgottenserver-x64.exe.
i got my config.lua configerd
i had this i run from powershell

PS D:\TibiaServer\servers\Server> .\theforgottenserver-x64
The Forgotten Server - Version 1.3
Compiled with Microsoft Visual C++ version 14.1
Compiled on Oct 11 2019 18:43:27 for platform x64

A server developed by Mark Samman
Visit our forum for updates, support, and resources: OTLand (http://otland.net/).

> Loading config
ERROR: Missing file key.pem.
No services running. The server is NOT online.
PS D:\TibiaServer\servers\Server>
this is intended AFAIK
sorry im
this is intended AFAIK
what do you mean sorry i cant get it, u mean it need a configration or so ?
 
Last edited:
OP
mesosot

mesosot

Premium User
Premium User
Joined
Aug 16, 2007
Messages
355
Best answers
0
Reaction score
5
you need to have this file in your server folder (where the exe is)

Worked like a charm
any way i could contact you ?

PS D:\TibiaServer\servers\Server> .\theforgottenserver-x64
The Forgotten Server - Version 1.3
Compiled with Microsoft Visual C++ version 14.1
Compiled on Oct 11 2019 18:43:27 for platform x64

A server developed by Mark Samman
Visit our forum for updates, support, and resources: OTLand (http://otland.net/).

> Loading config
Establishing database connection... MySQL 10.3.6
Running database manager
No tables were optimized.
Loading vocations
Loading items
Loading script systems
Loading lua libs
create_functions.lua [loaded]
defaults_move_event.lua [loaded]
register_monster_type.lua [loaded]
Loading lua scripts
#example.lua [disabled]
#example.lua [disabled]
["actions"]
spellbook.lua [loaded]
["talkactions"]
position.lua [loaded]
Loading monsters
Loading lua monsters
#example.lua [disabled]
Loading outfits
Checking world type... PVP
Loading map
Map size: 1000x1000.
Map loading time: 0.241 seconds.
Initializing gamestate
it just go off it shut down it wont get online
 
Last edited by a moderator:

Lucifer

Active Member
Joined
Dec 27, 2014
Messages
144
Best answers
0
Reaction score
31
Location
Sweden
Check in your config if you have same namn there like you have in world folder.
 
Top