• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

TalkAction BotShield Pro v3.1 [discontinued]

Status
Not open for further replies.
OP
Syntax

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,876
Best answers
0
Reaction score
266
Location
Texas
ok thankyou, will update to new version once i get back next week from vacation.
 

Matti96

Abyss
Joined
Apr 17, 2009
Messages
254
Best answers
0
Reaction score
45
Location
Poland/Germany
I think you have done a good JOB...
It seems all OK.
Many People are going to use it. ;)
 
OP
Syntax

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,876
Best answers
0
Reaction score
266
Location
Texas
will only work for latest 0.3.5 SVN rev. Which is not available to public, will update this once its released.
 
OP
Syntax

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,876
Best answers
0
Reaction score
266
Location
Texas
np, you might wanna wait for new version. will be all in one file since I know how todo it now.
 

Sir Juninho

New Member
Joined
May 4, 2009
Messages
85
Best answers
0
Reaction score
1
[03/08/2009 16:41:33] The Forgotten Server, version 0.3.5_SVN (Crying Damson)

[03/08/2009 16:41:34] > Current version information - version: 0.3.5_SVN, patch: 0, build: 0, timestamp: 0.
 
OP
Syntax

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,876
Best answers
0
Reaction score
266
Location
Texas
any errors? I'll update it in a few days, gtg to work right now
 

HeberPcL

[PowerOT.com.br]
Joined
Aug 21, 2007
Messages
1,281
Best answers
0
Reaction score
39
Location
Brazil
Error
PHP:
Lua Script Error: [CreatureScript Interface]
in a timer event called from:
mods/scripts/BotShield.lua:onJoinChannel

luaGetPlayerStorageValue(). Player not found

Lua Script Error: [CreatureScript Interface]
in a timer event called from:
mods/scripts/BotShield.lua:onJoinChannel

luaGetPlayerStorageValue(). Player not found

Lua Script Error: [CreatureScript Interface]
in a timer event called from:
mods/scripts/BotShield.lua:onJoinChannel

luaGetPlayerStorageValue(). Player not found

Lua Script Error: [CreatureScript Interface]
in a timer event called from:
mods/scripts/BotShield.lua:onJoinChannel

luaGetPlayerStorageValue(). Player not found

Lua Script Error: [CreatureScript Interface]
in a timer event called from:
mods/scripts/BotShield.lua:onJoinChannel

luaGetPlayerStorageValue(). Player not found

Lua Script Error: [CreatureScript Interface]
in a timer event called from:
mods/scripts/BotShield.lua:onJoinChannel

mods/scripts/BotShield.lua:54: attempt to compare number with boolean
stack traceback:
        mods/scripts/BotShield.lua:54: in function <mods/scripts/BotShield.lua:50>
0.3.5 Public
 
OP
Syntax

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,876
Best answers
0
Reaction score
266
Location
Texas
gotcha, ill update asap.
 
OP
Syntax

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,876
Best answers
0
Reaction score
266
Location
Texas
bump, mod is not working atm, since I hastily updated and it crashes with no error...so be patient

EDIT: fixed crashing errors but keep getting a buffer error which I am unfamiliar with. Maybe a bug in TFS? Probably the script though
 
Last edited:

zakius

Enter the Ninja!
Joined
Apr 30, 2009
Messages
2,635
Best answers
0
Reaction score
61
Location
with Taiga
Code:
[07/08/2009 13:53:15] Loading botshield.xml...[Error - ScriptingManager::loadFromXml] Cannot load mod mods/botshield.xml
[07/08/2009 13:53:15] Line: 1, Info: XML declaration allowed only at the start of the document
From the first version I had problems with this script.
And maybe you can make it working onLogin in server log without this stamina stuff?
Always when I tried this it was going crazy...

EDIT: need to delete few spaces at begin of script lol
 

ScorpiOOn93

etherno.net
Joined
Jun 19, 2008
Messages
662
Best answers
0
Reaction score
0
Location
CookieLand :DDD
Sorry but it's not working for me o_O
I've created a file called "botshield.xml" in folder "mods", My channelid for botshield is 13 and I was testing this script in fight (not in protected zone) and it wasn't working (nothing happend), of course i was testing it on 0.3.5, and btw when i opened a "botshield" channel by myself (from channel list) in console I had that error:
Lua Script Error: [Creaturescript Interface]
buffer

[string "loadBuffer"]:4 attemp to call method 'insert' <a nil value>
 
OP
Syntax

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,876
Best answers
0
Reaction score
266
Location
Texas
Sorry but it's not working for me o_O
I've created a file called "botshield.xml" in folder "mods", My channelid for botshield is 13 and I was testing this script in fight (not in protected zone) and it wasn't working (nothing happend), of course i was testing it on 0.3.5, and btw when i opened a "botshield" channel by myself (from channel list) in console I had that error:
I realize this error, and waiting for support, I think its an error in mod system, it'll be fixed soon.

bump, mod is not working atm, since I hastily updated and it crashes with no error...so be patient

EDIT: fixed crashing errors but keep getting a buffer error which I am unfamiliar with. Maybe a bug in TFS? Probably the script though
 
OP
Syntax

Syntax

Developer
Joined
Oct 10, 2007
Messages
2,876
Best answers
0
Reaction score
266
Location
Texas
If I could tell you how to help me fix it then I wouldn't need help would I? ;) I'm just waiting for some examples to come out so I know exactly what the error is.
 

slawkens

Developer
Premium User
Joined
Aug 27, 2007
Messages
3,019
Best answers
76
Reaction score
528
Location
Germany
If I could tell you how to help me fix it then I wouldn't need help would I? ;) I'm just waiting for some examples to come out so I know exactly what the error is.
hehe, exactly

I just looked in mod, and first what I see wrong - when you use "buffer", then there is no return, but _result

for example:
NOT
return TRUE

but
_result = true


and you have onLogout messed with channeljoin, it won't work
 

StreamSide

Joseluis Gonzalez
Support Team
Joined
Aug 31, 2007
Messages
3,418
Best answers
41
Reaction score
917
Location
Arica - Chile
why you use buffer? it should be script, or no?

edited:
iam starting to understand the mods...
i will try to fix it :D
 
Last edited:
Status
Not open for further replies.
Top