• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!
  • If you're using Gesior 2012 or MyAAC, please review this thread for information about a serious security vulnerability and a fix.

Error after Compiling


Apr 4, 2017
Reaction score
Hello everyone, I downloaded the sources from the OTX2 server, but I can't use the compiled distro because it has viruses, I've been trying for 3 days to compile the server, today I managed to (through Visual Studio, release/64-msvc), but when I open the executable, it presented me with some errors, at first, they were missing DLLs, I got the DLLs and it was disappearing error by error, until I got to this one, which I couldn't solve in any way, I'll leave an image below, but to stay longer Of course, I'll write down everything I've tried to do:

I tried to compile by Visual Studio in several ways, release 64, release 32, release gui 64, only the first one worked.

Release/32 Da esse erro: module machine type 'x64' conflicts with target machine type 'X86'

Release GUI/64 da esse erro: Error Lnk2001 Unresolved External Symbol Winmain

When I compiled by Release/64, I tried to open the .exe and it opened that windows error window and asked for some dlls, libeay32.dll, lua5.1.dll, sqlite.dll and libeay32.dll. (It had asked for sqlite.dll, but in VS I removed USE_SQLITE there in Properties > C/C++ > Preprocessor > Preprocessor Definitions and kept only USE_MYSQL).

I put the DLLs in the server folder and the DLLs errors disappeared, but now it has the following error:

I did a search and found that it could still be some DLL missing, so I used the program Dependencies_x64_Release to check, with it I found that it is not DLL, follow print:

I don't know what it could be, can anyone help me with that?

Thank you in advance!