[Gesior 2012] TOP Edition

Hiluxx

Celyon--baiak.net
Joined
Feb 23, 2009
Messages
43
Best answers
0
Reaction score
2
Location
Chile
im fix, thx and sorry for 1 post ! <3
 

Wilf0rd

New Member
Joined
Jan 6, 2015
Messages
5
Best answers
0
Reaction score
0
nice release rep+++! one problem with the shop though when purchasing outfits.

I'm using tfs 0.4 and when you purchase an outfit you constantly get an error message in the console:

[20:40:03.401] [Error - GlobalEvent Interface]
[20:40:03.404] data/globalevents/scripts/shop.lua:eek:nThink
[20:40:03.405] Description:
[20:40:03.406] (LuaInterface::luaDoCreateItemEx) Item not found

The script seems to believe it is an item. I've tried to purchase the outfit both when the char is online and offline. Anyone know how to solve it? It doesn't give the character the outfit and it crashes the server after a while.
 

Wilf0rd

New Member
Joined
Jan 6, 2015
Messages
5
Best answers
0
Reaction score
0
BUMP! :(

nice release rep+++! one problem with the shop though when purchasing outfits.

I'm using tfs 0.4 and when you purchase an outfit you constantly get an error message in the console:

[20:40:03.401] [Error - GlobalEvent Interface]
[20:40:03.404] data/globalevents/scripts/shop.lua:eek:nThink
[20:40:03.405] Description:
[20:40:03.406] (LuaInterface::luaDoCreateItemEx) Item not found

The script seems to believe it is an item. I've tried to purchase the outfit both when the char is online and offline. Anyone know how to solve it? It doesn't give the character the outfit and it crashes the server after a while.
 

Diarreamental

Member
Joined
Jul 6, 2015
Messages
110
Best answers
0
Reaction score
11
How i solve this?

Fatal error: Call to a member function fetchAll() on boolean in C:\xampp\htdocs\pages\latestnews.php on line 512


PHP:
            </form>
        </td>
    </tr>
</table>
<hr/>';
}


 512 line >>>   $last_threads = $SQL->query('SELECT ' . $SQL->tableName('players') . '.' . $SQL->fieldName('name') . ', ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('post_text') . ', ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('post_topic') . ', ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('icon_id') . ', ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('post_smile') . ', ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('id') . ', ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('replies') . ', ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('post_date') . ' FROM ' . $SQL->tableName('players') . ', ' . $SQL->tableName('z_forum') . ' WHERE ' . $SQL->tableName('players') . '.' . $SQL->fieldName('id') . ' = ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('author_guid') . ' AND ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('section') . ' = 1 AND ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('first_post') . ' = ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('id') . ' ORDER BY ' . $SQL->tableName('z_forum') . '.' . $SQL->fieldName('last_post') . ' DESC LIMIT ' . $config['site']['news_limit'])->fetchAll();
    
    //Here start news
    if(isset($last_threads[0]))
    {
        foreach($last_threads as $thread)
        {
            $main_content .= '
                <div class="NewsHeadline">
                    <div class="NewsHeadlineBackground" style="background-image:url('.$layout_name.'/images/news/newsheadline_background.gif)">
                        <img src="'.$layout_name.'/images/news/icons/newsicon_'.$thread['icon_id'].'.gif" class="NewsHeadlineIcon" alt=\'\' />
                        <div class="NewsHeadlineDate">'.date('M m Y', $thread['post_date']).' -</div>
                        <div class="NewsHeadlineText">'.htmlspecialchars($thread['post_topic']).'</div>
                    </div>
                </div>
                <table style=\'clear:both\' border=0 cellpadding=0 cellspacing=0 width=\'100%\'>
                <tr>';
            $main_content .= '
                <td style=\'padding-left:10px;padding-right:10px;\' >' . showPost('', $thread['post_text'], $thread['post_smile']) . '<br><p align="right"><a href="?subtopic=forum&action=show_thread&id=' . $thread['id'] . '">» Comment on this news</a></p></td>';
        
            $main_content .= '
                <td>
                    <img src="'.$layout_name.'/images/global/general/blank.gif" width=10 height=1 border=0 alt=\'\' />
                </td>
            </tr>
        </table><br />';
        }
    }
    else
        $main_content .= '<h3>No news. Go forum and make new thread on board News.</h3>';
 

Pluto

Premium User
Premium User
Joined
Jun 14, 2017
Messages
8
Best answers
0
Reaction score
3
Location
Poland
Adding news // forum stuff doesn't show UTF-8 characters, just LATIN one (I guess) or something else. Any idea how to fix it? It doesn't happen when you edit the page (shows char correctly), but add news or forum posts through the scripts. I just can't find it, any ideas?
 

therrax

Intermediate OT User
Joined
Jul 12, 2012
Messages
258
Best answers
1
Reaction score
8
will be updated to the version otx3-tfs 1.x?
 
Top