CreatureEvent [TFS 1.1] Random Item Stats

Kungenn

Advanced OT User
Joined
Jun 10, 2007
Messages
1,511
Best answers
0
Reaction score
219
Location
USA California
Im currently trying it on a fresh copy of TFS 1.1 done in 2 minutes, Ill post results

##Exactly the same issue with TFS1.1, lootless monsters. You must have posted either incorrect information or code. Cause I have added what you wrote 5 times now and it still doesn't work
 

Leo32

Getting back into it...
Joined
Sep 21, 2007
Messages
730
Best answers
1
Reaction score
124
Im currently trying it on a fresh copy of TFS 1.1 done in 2 minutes, Ill post results

##Exactly the same issue with TFS1.1, lootless monsters. You must have posted either incorrect information or code. Cause I have added what you wrote 5 times now and it still doesn't work
Realised I'm missing Container.cpp/h edits in the post...
Will have to wait, sorry.
 

Extrodus

Veteran OT User
Joined
Dec 22, 2008
Messages
2,288
Best answers
1
Reaction score
283
Location
Canada, Eh?
@Kungenn - Couldn't tell you really.. I just imported it and it worked as intended. The only errors being the ones stated in the post previously, for example: bows dont actually get extra attack or range. So Bow weapons are pointless to be in the script.
 

Kungenn

Advanced OT User
Joined
Jun 10, 2007
Messages
1,511
Best answers
0
Reaction score
219
Location
USA California
@Kungenn - Couldn't tell you really.. I just imported it and it worked as intended. The only errors being the ones stated in the post previously, for example: bows dont actually get extra attack or range. So Bow weapons are pointless to be in the script.
Are you talking about Leo32's edits or the thread starter mod?
 

Allesn

Member
Joined
May 4, 2011
Messages
208
Best answers
1
Reaction score
23
Works on 1.2? Because i'm using this, I kill some monsters and nothing happens
 

vafeze

New Member
Joined
Jul 5, 2009
Messages
8
Best answers
0
Reaction score
1
zbizu, what i need to do to attackspeed increments works? im using tfs 1.2
 

Zothion

Veteran OT User
Joined
Apr 28, 2014
Messages
1,092
Best answers
0
Reaction score
378
if its works on 1.1 it works on 1.2 most likely
 

_M4G0_

Well-Known Member
Joined
Feb 6, 2016
Messages
425
Best answers
13
Reaction score
69
[FIX]Loot from players red skull

[/IMG]
 

Taurus

Texass
Joined
Jan 11, 2009
Messages
615
Best answers
2
Reaction score
30
Location
United States
This is super-dope. Zero errors.

Thank you Cykotitan and zbizu. I'm using this on the server my family is playing together. Thanks for posting the script.
 

tompanhuhu

New Member
Joined
Oct 28, 2016
Messages
1
Best answers
0
Reaction score
0
The scripts works, items get's stats.

But the console spits our errors =/


Code:
Lua Script Error: [Main Interface]
in a timer event called from:
(Unknown scriptfile)
data/creaturescripts/scripts/custom/randomstats.lua:138: attempt to index local 'it_u' (a nil value)
stack traceback:
        [C]: in function '__index'
        data/creaturescripts/scripts/custom/randomstats.lua:138: in function 'assign_loot_Stat'
        data/creaturescripts/scripts/custom/randomstats.lua:252: in function <data/creaturescripts/scripts/custom/randomstats.lua:247>
 
Top