OpenTibia DLL Pack (v2.0)

Mark

Administrator
Staff member
Administrator
Joined
May 27, 2007
Messages
6,387
Reaction score
1,384
Location
Sweden
This is a package of the required DLL files to run an OpenTibia server.

The DLL files were compiled with Microsoft Visual Studio, which means that you might need the C++ Redistributable Packages to use them (most people already have it installed, but if you don't, you're going to need it).
32-bit C++ redistributable package: Download: Microsoft Visual C++ 2010 Redistributable Package (x86) - Microsoft Download Center - Download Details
64-bit C++ redistributable package: Download: Microsoft Visual C++ 2010 Redistributable Package (x64) - Microsoft Download Center - Download Details

Files:
Code:
[B]DLL File            Version        Description[/B]
iconv.dll           1.14.0.0       Iconv
libeay32.dll        0.9.8          OpenSSL
libmysql.dll        6.0.0          MySQL Library
libxml2.dll         2.7.8          XML Library
lua51.dll           2.0.0-beta9    LuaJIT Library
sqlite.dll          3.7.7.1        SQLite Library
zlib1.dll           1.2.5          Data (De)Compression Library
If you downloaded a 64-bit distribution, you will need the 64-bit DLL files, if not, then it is most likely the 32-bit DLL files.

Download OpenTibia DLL Pack:
 

Attachments

Fablow

RealOpenTibia.com
Premium User
Joined
May 7, 2008
Messages
1,443
Reaction score
47
Location
Canada
Nice release Talaturen. I'm glad you guys released 0.3.7.
 

Tryller

Member
Joined
Nov 22, 2010
Messages
199
Reaction score
12
Location
Brazil
Tala update pack
0.3.7 is compiled with luajit.
I need luajit_setmode.dll
and lua5.1.dll
 
OP
Mark

Mark

Administrator
Staff member
Administrator
Joined
May 27, 2007
Messages
6,387
Reaction score
1,384
Location
Sweden
Tala update pack
0.3.7 is compiled with luajit.
I need luajit_setmode.dll
and lua5.1.dll
0.3.7 is indeed compiled with LuaJIT, and lua51.dll is LuaJIT DLL so I don't see the problem.
 
OP
Mark

Mark

Administrator
Staff member
Administrator
Joined
May 27, 2007
Messages
6,387
Reaction score
1,384
Location
Sweden
I can't run server baucause need that dlls
The DLL's are in the package, if you have placed them in the same directory as the server and it doesn't run you have probably mixed 32-bit DLL files with 64-bit server or the other way around.
 

Mazen

Developer
Joined
Aug 20, 2007
Messages
612
Reaction score
36
Location
Sweden
I bet you're using linux. That version of iconv is very hard to compile on Windows, you'll be forced to use mingw. However I found a solution to go around that by downgrading to 1.11.

libiconv 1.11: http://libiconv.sourceforge.net/libiconv-1.11-msvc.tar.gz

Just follow the instructions to compile. Also otserv doesn't need 1.14 so don't worry.

EDIT: TFS 0.4 is using an additional library called mpir.
 
Top