RL Map 10.98

tabarane

New Member
Joined
Sep 8, 2019
Messages
2
Best answers
0
Reaction score
0
Location
Russia
HI everyone,

im a new on deploying my own ots to test and have fun with real fun, so we are using current TFS 1.2 RL Map but its outdated since 10.95 and latest boss is roshamol and oramnd

im not quite clear in understand the map and data-pack, i thought if i deploy TFS1.3 (10.98) i would have the more updated version, but i understand i need to get data-pack

can you please explain for me difference between TFS running server and the maps to run, like what is the requirements in order for the TFS to load the Map correctly

i tried to add maps but i get error with monestors not found or NPC not found etc
 

Shadow_

Well-Known Member
Joined
Jun 2, 2018
Messages
416
Best answers
16
Reaction score
97
Location
Cairo, Egypt
First you should use tfs 1.3 i was using 1.2 but changing to 1.3 is not hard at all you just have to change few things in spells and we can handle it in this thread so using tfs 1.2 datapack will work with tfs 1.3 because the difference between them in scripting interface is only addCondition & setCondition and you can know the changes here otland/forgottenserver (https://github.com/otland/forgottenserver/wiki/Changelog-1.3)
 
OP
T

tabarane

New Member
Joined
Sep 8, 2019
Messages
2
Best answers
0
Reaction score
0
Location
Russia
Update:

i was able to start the server with my old datapack from TFS1.2 , but i got a lot of errors,

server is running but it looks like there is conflict with creatures, items , npc etc






i started TFS1.3 , named data folder to data.old , copied TFS2 data folder to the TFS 1.3 location, changed the world map name in config.lua in TFS1.3,and started the server and i keep geeting this error , is there a way to point out the config file, or did i do something wrong?

also question is, this mean with the new version of TFS1.3 i still dont have the latest Items , quests , creatures from latest update, how i can get them?
just point me out to the correct direction :)

Thanks alot for help, and i hope this topic can help others as well

1568020540686.png
 

Attachments

Last edited:

Sparkles

snek
Premium User
Joined
Mar 1, 2009
Messages
168
Best answers
13
Reaction score
68
Location
Norway
Make sure that the config.lua is in the same folder as the .exe you're trying to run - Make sure to edit the config to let it connect to the database you're using.
As for a datapack, a quick dip into the downloads section and ta-da:
Just download the datapack and the map and smack it into that server and voilà ur good to go.
 
Top