SIMPLE ALL IN ONE: From nothing to a fully working dedicated server on Ubuntu

Discussion in 'Basic' started by Don Daniello, Mar 27, 2014.

  1. Itutorial

    Itutorial Well-Known Member

    Joined:
    Dec 23, 2014
    Messages:
    1,001
    Likes Received:
    163
    Best Answers:
    12
    Turns out I put deban 7 not ubuntu lmfao
     
  2. LuckyM

    LuckyM Ett är Ett

    Joined:
    Jun 13, 2009
    Messages:
    1,362
    Likes Received:
    142
    Best Answers:
    0
    Got a little problem here. I'm using Ubuntu 16.04 LTS

    Code (Text):
    1. fatal: [localhost]: FAILED! => {"changed": true, "cmd": ["loginctl", "enable-linger", "otsmanager"], "delta": "0:00:00.003295", "end": "2017-04-05 22:37:40.423427", "failed": true, "rc": 1, "start": "2017-04-05 22:37:40.420132", "stderr": "Failed to create bus connection: No such file or directory", "stdout": "", "stdout_lines": [], "warnings": []}
    Solution for this error is "apt-get update && apt-get install -y dbus"

    Thanks to @HalfAway

    Have been looking around in google without any response :/
     
    Last edited: Apr 6, 2017
  3. kefu

    kefu war-ots.com

    Joined:
    Feb 11, 2010
    Messages:
    9
    Likes Received:
    0
    Best Answers:
    0
    good job
     
    Last edited: Sep 17, 2017
  4. Itutorial

    Itutorial Well-Known Member

    Joined:
    Dec 23, 2014
    Messages:
    1,001
    Likes Received:
    163
    Best Answers:
    12
    Can you connect to your website?
     
  5. kefu

    kefu war-ots.com

    Joined:
    Feb 11, 2010
    Messages:
    9
    Likes Received:
    0
    Best Answers:
    0
    site working but i cant login to game port its open i dont have idea why this dont work :/

    if i try connect in client 10.76 i se this
    [​IMG]

    if try in client 10.98 i see timeout (10060)
     
  6. Itutorial

    Itutorial Well-Known Member

    Joined:
    Dec 23, 2014
    Messages:
    1,001
    Likes Received:
    163
    Best Answers:
    12
    @Don Daniello

    When I try to connect to my IP it just takes me to my database rather than the website. Any idea what it could be?
     
  7. Tinkz

    Tinkz Member

    Joined:
    Feb 14, 2012
    Messages:
    118
    Likes Received:
    20
    Best Answers:
    3
    Where can I find the tfs log? I want to be able to see the errors a that occur while starting it tfs.
     
  8. Don Daniello

    Don Daniello /root Staff Member Administrator

    Joined:
    Apr 11, 2008
    Messages:
    3,292
    Likes Received:
    539
    Best Answers:
    6
    That's not possible if the script ran correctly.

    You will see instructions when you log in as otsmanager.
     
  9. Tinkz

    Tinkz Member

    Joined:
    Feb 14, 2012
    Messages:
    118
    Likes Received:
    20
    Best Answers:
    3
    @Don Daniello I know that if i write log tfs it will show me the log, but i´d like to find the log as an txt file, where is it saved?
     
  10. Don Daniello

    Don Daniello /root Staff Member Administrator

    Joined:
    Apr 11, 2008
    Messages:
    3,292
    Likes Received:
    539
    Best Answers:
    6
    It's is not saved as text file, it's written to journald.
     
  11. Tinkz

    Tinkz Member

    Joined:
    Feb 14, 2012
    Messages:
    118
    Likes Received:
    20
    Best Answers:
    3
    @Don Daniello I´m trying to convert tfs 0.4 data to tfs 1.2. I´m starting with for example actions, the log will then allow me to see what errors and I can easly work on them. Then when i want to work on for example spells, the log would just be too long, does it have a way to clean the log?

    Work with actions - > see all errors in log tfs - > clean - > work on spells - > clean? is that possible?
     
  12. Don Daniello

    Don Daniello /root Staff Member Administrator

    Joined:
    Apr 11, 2008
    Messages:
    3,292
    Likes Received:
    539
    Best Answers:
    6
    No, there is no way to clean log but there are many ways to filter it. You should read journalctl, it will tell you how to show log from a certain point in time, that would be the simplest solution for you.
     
  13. Tinkz

    Tinkz Member

    Joined:
    Feb 14, 2012
    Messages:
    118
    Likes Received:
    20
    Best Answers:
    3
    I don´t understand the journalctl, i guess ill just reboot my ubuntu everytime i fix something. Like Fix actions - > reboot ubuntu - > work with movements - > reboot so that the log is clean for me to see.
     
  14. fipayoyo

    fipayoyo New Member

    Joined:
    Mar 4, 2016
    Messages:
    17
    Likes Received:
    0
    Best Answers:
    0
    Hey @Don Daniello
    I'm getting weird error when I try to make project (it's work on windows)
    I dunno why there is problem with this method while on windows works fine

    //NVM
    I found solution on wiki, great job!
     
    Last edited: Aug 3, 2017
  15. Tinkz

    Tinkz Member

    Joined:
    Feb 14, 2012
    Messages:
    118
    Likes Received:
    20
    Best Answers:
    3
    @Don Daniello why am I getting this? I compiled exactly how i´m supposed to do.


    [​IMG]
     
    Last edited: Sep 6, 2017
  16. Don Daniello

    Don Daniello /root Staff Member Administrator

    Joined:
    Apr 11, 2008
    Messages:
    3,292
    Likes Received:
    539
    Best Answers:
    6
    Try rebooting your server first.
     
  17. andjelo96

    andjelo96 Member

    Joined:
    Jun 22, 2016
    Messages:
    318
    Likes Received:
    18
    Best Answers:
    3
    @Don Daniello Why you just dont make video for your Hosting Service? Example From Nothing to Fully Working OT Hosting Service , tfs 0.3.6,1.x etc.. it wont cost you much but you would help us a lot ;]
     
  18. Tinkz

    Tinkz Member

    Joined:
    Feb 14, 2012
    Messages:
    118
    Likes Received:
    20
    Best Answers:
    3
    Worked after rebooting the server
     
    Last edited: Sep 7, 2017
  19. Yuggi

    Yuggi Member

    Joined:
    May 18, 2017
    Messages:
    49
    Likes Received:
    3
    Best Answers:
    0
    I'm trying to use coredumpctl too, when I try it it says the "command not found" same as it did for @imkingran
    Using ubuntu 16.04.3

    I have been tryign to google a fix but with no success, does someone know how I can get it to work or see a debug log another way with this system?
    @Don Daniello
     

Share This Page

Loading...