• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

[SOLVED] My 8.6 server says that only 10.98 client allowed.

kudpa

New Member
Joined
Jun 9, 2013
Messages
2
Best answers
0
Reaction score
1
Hello guys,
I'm just trying to run server for my own entertainment.
I'm using The Forgotten Server 1.2, I downloaded the source files from the first post in this thread:
[8.60] The Forgotten Server 1.2

It's supposed to support the 8.6 client and I've managed to compile the server and connect it to a database but when I try to login using a 8.6 client, a window comes up saying something like 'only 10.98 client allowed'. I'm really lost as to why this is happening, I'm fairly sure I downloaded the source code that's provided in the first post in that thread and no one else there seems to have a similar problem.

I tried both, logging in without an acc number and password, and also creating an account in xampp and logging in with that. Same result both times.

If this is a noob question then sorry, I'm only a beginner at this.

Any ideas as to what's happening are appreciated.
 

Random Number

Banned User
Joined
Oct 30, 2017
Messages
49
Best answers
2
Reaction score
21
I checked the github definitions.h and it says
C++:
static constexpr auto CLIENT_VERSION_MIN = 1097;
static constexpr auto CLIENT_VERSION_MAX = 1098;
static constexpr auto CLIENT_VERSION_STR = "10.98";
forgottenserver/definitions.h at master · ninjalulz/forgottenserver · GitHub

Maybe he deleted the old repo and replaced not realizing people still might be using it. There is an alternative version of TFS which uses the same code structure for 8.6.
You can try this is see if that works for you.
C++:
static constexpr auto CLIENT_VERSION_MIN = 860;
static constexpr auto CLIENT_VERSION_MAX = 860;
static constexpr auto CLIENT_VERSION_STR = "8.60";
otxserver/definitions.h at otxserv3 · mattyx14/otxserver · GitHub
otxserver/path_8_6 at otxserv3 · mattyx14/otxserver · GitHub
 

2Rec

Excellent OT User
Joined
Jul 31, 2013
Messages
523
Best answers
47
Reaction score
724
I checked the github definitions.h and it says
C++:
static constexpr auto CLIENT_VERSION_MIN = 1097;
static constexpr auto CLIENT_VERSION_MAX = 1098;
static constexpr auto CLIENT_VERSION_STR = "10.98";
forgottenserver/definitions.h at master · ninjalulz/forgottenserver · GitHub

Maybe he deleted the old repo and replaced not realizing people still might be using it. There is an alternative version of TFS which uses the same code structure for 8.6.
You can try this is see if that works for you.
C++:
static constexpr auto CLIENT_VERSION_MIN = 860;
static constexpr auto CLIENT_VERSION_MAX = 860;
static constexpr auto CLIENT_VERSION_STR = "8.60";
otxserver/definitions.h at otxserv3 · mattyx14/otxserver · GitHub
otxserver/path_8_6 at otxserv3 · mattyx14/otxserver · GitHub
That's because you're checking on a master branch...
This is the right one:
forgottenserver/src at 8.6 · ninjalulz/forgottenserver · GitHub
 
OP
K

kudpa

New Member
Joined
Jun 9, 2013
Messages
2
Best answers
0
Reaction score
1
I am indeed a noob. It turns out that I downloaded the files from the master branch. Weirdly, when I tried to get the repo using git clone, the same thing happened again and it downloaded wrong files, so I chose download as zip and got the correct files. I compiled and everything's working great.

So, thank you for the help guys. I can now log in.
 
Top