• Vote in May Mapping Competition to select a winner!
  • There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!

OTClient Unable to create item with invalid id

Yalasari

Active Member
Joined
Jul 16, 2017
Messages
81
Best answers
8
Reaction score
44
Hello,

While trying to add new item to server I encountered a problem, and after 2 days i don't have idea how to fix it:

36118

Everything on server side is ok, i think because console doesn't show any errors

Here's how everything is set up:
items.otb:
36116
.SPR and .DAT files
36117

We are using 10.98 files
Also, i can't use classic client to verify this because we have done some protocol changes (which doesn't affect item system).

I would appreciate any help.
 

Apollos

Dude who does stuff
Joined
Apr 22, 2009
Messages
756
Best answers
114
Reaction score
520
Location
United States
Hello,

While trying to add new item to server I encountered a problem, and after 2 days i don't have idea how to fix it:

View attachment 36118

Everything on server side is ok, i think because console doesn't show any errors

Here's how everything is set up:
items.otb:
View attachment 36116
.SPR and .DAT files
View attachment 36117

We are using 10.98 files
Also, i can't use classic client to verify this because we have done some protocol changes (which doesn't affect item system).

I would appreciate any help.
Could be because the ware id in otb isn't the same as in dat. Try reloading the item in itemeditor to fix it or change it manually to 23726.
 

Narg

New Member
Joined
Jul 11, 2012
Messages
5
Best answers
0
Reaction score
0
Hello,

While trying to add new item to server I encountered a problem, and after 2 days i don't have idea how to fix it:

View attachment 36118

Everything on server side is ok, i think because console doesn't show any errors

Here's how everything is set up:
items.otb:
View attachment 36116
.SPR and .DAT files
View attachment 36117

We are using 10.98 files
Also, i can't use classic client to verify this because we have done some protocol changes (which doesn't affect item system).

I would appreciate any help.
Did you find a solution for this?
 
OP
Yalasari

Yalasari

Active Member
Joined
Jul 16, 2017
Messages
81
Best answers
8
Reaction score
44
Did you find a solution for this?
Yes i did, post marked as best answer led me to cause of problems:
Client ID in .otb and Client ID in .dat was different, therefore client was confused and unable to create item
 

Narg

New Member
Joined
Jul 11, 2012
Messages
5
Best answers
0
Reaction score
0
Hmm, when I reloaded my item, the Wareid was set to 0, leaving it as 0 gives me the error, so does copying the clientID in the wareID... I'm lost here haha
 
Top