• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!
  • If you're using Gesior 2012 or MyAAC, please review this thread for information about a serious security vulnerability and a fix.

Convert a 7.4 map to be compatible with 7.6/7.72

fschuindt

Member
Joined
Oct 11, 2012
Messages
41
Reaction score
14
Location
Brazil
GitHub
fschuindt
Hi there,

I own a 7.4 map, but this is really a 7.4, not a 7.6/7.72 with sprites changed to look like 7.4. It's really a 7.4 map.
My goal is to run this map with the Nekiro's TFS 1.5 downagrades to 7.72, but this downgrade will only support 7.6/7.72 maps. My 7.4 map isn't supported.

I'm looking for someone that could convert my map to be compatible with the Nekiro's downgrade or to change the Nekiro's downgrade so it would accept my 7.4 map. The idea is to be able to play my map using a 7.72 client but with the 7.4 sprites over Nekiro's fork. It would be a 7.72 client with the 7.4 Tibia.dat and Tibia.spr files.

I don't plan to send the original map files over, but I have created a small 7.4 map by copying a random section of the original map and saving it as a different file. So I'm attaching this sample 7.4 map on this message, compressed with the RME files for the ./data/740 folder if someone wants to take a look. As for the "Tibia installation path" that RME asks, you should use the Cipsoft's vanilla 7.4 path with the original 7.4 Tibia.dat and Tibia.spr files.

If you think this is something you can do, please let me know so we can arrange this service. Remember that the map I'm sending here is just a sample, whatever the conversion method will be, it must work on the real map. But that we can discuss further in another moment.

Download the sample 7.4 map with RME files: to_convert (https://www.mediafire.com/file/6o3kxc5i3tgstzf/to_convert.zip/file)

Note: Using RME 3.7 works for me, I do get some warnings but nothing major.

Thank you!
 

danilopucci

Active Member
Joined
Nov 22, 2019
Messages
76
Solutions
2
Reaction score
45
GitHub
danilopucci
Could you post the solution? @danilopucci
Hello glapa!

This should work:

If you want to see only code that I changed, you can find the implementation here:
 
G

glapa93

Guest
Hello glapa!

This should work:

If you want to see only code that I changed, you can find the implementation here:
Hey, buddy. These are old commits, which are already implemented in 1.5 downgraded distribution. What I want to do is to convert tibia.dat and tibia.spr from client 7.4 to run on 7.72 so I dont have to replace thousands of graphics manually. Do you know how to do it?
 

danilopucci

Active Member
Joined
Nov 22, 2019
Messages
76
Solutions
2
Reaction score
45
GitHub
danilopucci
Hey, buddy. These are old commits, which are already implemented in 1.5 downgraded distribution. What I want to do is to convert tibia.dat and tibia.spr from client 7.4 to run on 7.72 so I dont have to replace thousands of graphics manually. Do you know how to do it?
If you are using OTClient, you don't need to do this.

If you are using Cipsoft client, you can try to edit .spr and .dat signatures by hexedit. The signatures are four first bytes of the files. I am not sure if it works, but you can try.

I don't know if you are aware of, but there are some topics about the map/items issues which everybody faces, and I covered it here:
 
Top