Does anyone have a newer version of login.php that accepts new clients? like 11.70+? thank you

hacuna

Well-Known Member
Joined
Sep 24, 2010
Messages
19
Reaction score
0
I need a lot to use on my server, would anyone know how do I use a recent version of Tibia Client on my server? it only accepts the 11.49 client. I would like to use a newer version, thank you very much for the attention.
 

Znote

<?php echo $title; ?>
Staff member
Global Moderator
Premium User
Joined
Feb 14, 2008
Messages
6,466
Reaction score
1,156
Location
Norway, Oslo
Could you link to a distribution that is available as open source and supports 11.70?
OTX only supports up to 11.49.

I have seen some servers that support 11.70+, but they are violating the GNU General Public License v2.0 by keeping the source code private.
 

Felipe93

Ghost Member
Joined
Mar 21, 2015
Messages
1,351
Reaction score
188
Location
Chile
indeed its supporting 11.70

static constexpr auto CLIENT_VERSION_MIN = 1100;
static constexpr auto CLIENT_VERSION_MAX = 1171;
static constexpr auto CLIENT_VERSION_STR = "11.71";
 

jo3bingham

Legendary OT User
Joined
Mar 3, 2008
Messages
992
Reaction score
424
Could you link to a distribution that is available as open source and supports 11.70?
OTX only supports up to 11.49.

I have seen some servers that support 11.70+, but they are violating the GNU General Public License v2.0 by keeping the source code private.
Don’t forget the PR I made for your AAC supported up to version 11.75 at the time (maybe even up to 11.9x now).

The GNU license states that the source code only needs to be available if you distribute the software. Technically, hosting an OT with modified TFS source code is exempt because you’re not distributing the executable. However, if someone were to release it as a “distro” then, yes, they would need to supply the source code with it.
 

EduardoDantas

Well-Known Member
Joined
Sep 25, 2013
Messages
65
Reaction score
12
Could you link to a distribution that is available as open source and supports 11.70?
OTX only supports up to 11.49.

I have seen some servers that support 11.70+, but they are violating the GNU General Public License v2.0 by keeping the source code private.


Open source, 12.0

However, I did not find login.php to work.35653
 
Last edited:
Top