• There is NO official Otland's Discord server and NO official Otland's server list. The Otland's Staff does not manage any Discord server or server list. Moderators or administrator of any Discord server or server lists have NO connection to the Otland's Staff. Do not get scammed!
  • If you're using Gesior 2012 or MyAAC, please review this thread for information about a serious security vulnerability and a fix.

[SOLVED] TFS 1.5 with 7.72 downgrade exits at "Loading map" - abort() called


Active Member
Mar 10, 2020
Reaction score
I've downloaded Nekiro's 7.72 downgrade and last supported version of TFS (at commit 17bf63).

I've compiled Nekiro's vc17/theforgottenserver.sln in Visual Studio 2022 and moved the .exe and .dlls from vc17/x64/Debug/ to main TFS directory. I've run it but it was still missing some dlls, so I've copied them from TFS 1.5 (zlib1.dll, zlibd1.dll, zstd.dll). Tried to run TFS again but now it exits at "Loading map" and throws a popup:
Microsoft Visual C++ Runtime Library
Debug Error!

Program: C:\Users\xxx\Desktop\TFS-nekiro\tfs.exe

abort() has been called

(Press Retry to debug the application)

Abort Retry Ignore
There are no logs in tfs/data/logs directory.

Btw. it also complained about items.otb so I've removed the code that was throwing this error.
And about missing changegold.lua so I've removed it from actions.xml as well.

EDIT. Fixed by renaming the map file in config.lua (from forgotten to world)
Last edited: